Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

PPPd connection problem

Posted on 1999-08-21
6
Medium Priority
?
258 Views
Last Modified: 2013-12-15
Hi. I cannot connect to ISP. Kppp detects my modem, then I dial up ISP's number, after terminal window comes up, I enter login ID, password, click continue and nothing goes further. Error msg states that connection terminated due timeout, waiting for ppp interface to come up,ERROR 15. In log window I see those guarbige letters,in title bar - starting pppd. In task manager I see that PPPD process starts, then, after timeout value, it of course, terminates.
Can anyone explain what's wrong with this?, why this PPP interface does not come up? ANd how can I solve this problem? (i tried to send "enter" when i used script, but still get the same error, and pppd anyway starts after this)
In NT i use terminal window as well but after garbage letters i press done (on term window) and everything is ok.
When I checked pppstatistics i noticed that my comp transmits some packets but does not receive any.
I use OpenLinux 2.2.
Thank you in advance
0
Comment
Question by:mazaii
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 2
6 Comments
 

Author Comment

by:mazaii
ID: 1630476
Edited text of question.
0
 
LVL 2

Expert Comment

by:gravity
ID: 1630477
Does the following work ? :

(you have to be root)

load up minicom by typing "minicom" in your terminal window.

type atdt (your isps phone no.)

enter your login details

press "alt-q" or "ctrl-q" to quit out of minicom.

type "pppd -d -detach (the path to your modem device) 38400 &

and then everything should work. Does it ?
0
 

Author Comment

by:mazaii
ID: 1630478
Thank for advice, Gravity, but unfortunately i do not have minicom on my system, though i tried with seyon app. still just does not want to connect. I have no idea why ppp interface does not come up. I noticed on my NT(when i dialed
to ISP) wins database registers IP which was assigned by ISP.? so i tried some arguments with pppd - no sign of movement any further.
Ok, thank anyway for the advice.
0
Independent Software Vendors: We Want Your Opinion

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

 

Accepted Solution

by:
leolara earned 20 total points
ID: 1630479
Same thing happened to me until I gave up and start running wvdial, a small program that works very well. It´s available at alternex.linuxberg.com
0
 
LVL 2

Expert Comment

by:gravity
ID: 1630480
If you're still interested in seeing if you can physically dial in to your isp, you can get minicom @ :

http://metalab.unc.edu/pub/Linux/apps/serialcomm/dialout/minicom-1.82.1.src.tar.gz
0
 

Author Comment

by:mazaii
ID: 2040829
No minicom, wvdial worked.
I've found ppp-on script,changed variables and it worked(with my former ISP...), now i have another problem, with my new ISP. Even this script does not work for me anymore
:-(
I posted another question
Thank you all
0

Featured Post

New benefit for Premium Members - Upgrade now!

Ready to get started with anonymous questions today? It's easy! Learn more.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I. Introduction There's an interesting discussion going on now in an Experts Exchange Group — Attachments with no extension (http://www.experts-exchange.com/discussions/210281/Attachments-with-no-extension.html). This reminded me of questions tha…
Fine Tune your automatic Updates for Ubuntu / Debian
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
This demo shows you how to set up the containerized NetScaler CPX with NetScaler Management and Analytics System in a non-routable Mesos/Marathon environment for use with Micro-Services applications.
Suggested Courses

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question