Avatar of psiess
psiessFlag for United States of America asked on

SCO Unix - Default Gateway

I have a SCO Unix box on my network that was never properly configured and I'm trying to fix that.  I was able to get DNS happening (created /etc/resolv.conf).  

The problem I'm having now is with the default gateway.  

I've tried the following command:

  route add default -net <router ip address> 0

but I still can't traceroute or ping anything outside my network.  I get a DNS lookup no problem, but ping returns "no route to host"


HELP!!!!!!!!!!!!!!



Unix OS

Avatar of undefined
Last Comment
dgrimes

8/22/2022 - Mon
ASKER CERTIFIED SOLUTION
dgrimes

Log in or sign up to see answer
Become an EE member today7-DAY FREE TRIAL
Members can start a 7-Day Free trial then enjoy unlimited access to the platform
Sign up - Free for 7 days
or
Learn why we charge membership fees
We get it - no one likes a content blocker. Take one extra minute and find out why we block content.
See how we're fighting big data
Not exactly the question you had in mind?
Sign up for an EE membership and get your own personalized solution. With an EE membership, you can ask unlimited troubleshooting, research, or opinion questions.
ask a question
ASKER
psiess

I can reach any host on my own network from the SCO box.

The SCO host sits behind a firewall.  I'm trying to set up routing that will allow me to reach hosts outside.


dgrimes

Does your firewall support nat or pat? Is the inside nic using the same network ID as the server in question or is it on a separate subnet? What does you network look like?

Example:

INTERNET -- router -- (outside)firewall(inside) -- server

Is this how it looks? If your server is sitting behind your firewall then you need to set your default gateway to point to your firewall. Your firewall should take care of assigning the appropriate IP address to your packets and then forward them to your router.

Are you able to access the internet through other systems or work stations through a browser?

ASKER
psiess

My network goes

Internet -> firewall -> router.

I have (I think) the router set up as the default gateway.  
Entered the following command:
  route add default -net <ip address> -netmask <netmask>


I started with Experts Exchange in 2004 and it's been a mainstay of my professional computing life since. It helped me launch a career as a programmer / Oracle data analyst
William Peck
dgrimes

What network is your router on and what network is the server on? Does the router support nat or pat? What are you using for a firewall? Is it dual homed? Typically, firewalls are not placed directly to the Internet. Usually a router will sit between the Internet and firewall. Are you able to browse or ping from other systems on your internal network?
ASKER
psiess

You are right.  There is another router outside the firewall.  It is on a different network from our internal network.  

Our firewall does use NAT.

All of the other nodes on the network can ping to the outside.

dgrimes

OK.. Check 3 things:

1. Verify that you have set your default route to the same IP that the other systems are using. Remember, if your inside router is on the same network (same network ID) as the server, you do not want to use the -net option on the route command. You won't even need the -netmask option. Just use: route add default <IP Address>.

2. Configure your name daemon to act as a caching only server. Create a named.boot file in the /etc directory. Add the following to it:

directory       /etc/named.d
cache           .                      root.cache
primary         0.0.127.in-addr.arpa   named.local




This will configure you system as a caching only name server. It will not provide any naming service to any other systems.


3. Check your resolv.conf file. All that should be in it is:

domain           your.domain.name
hostresorder     local bind
nameserver       xxx.xxx.xxx.xxx


xxx.xxx.xxx.xxx is the ip address of your name server. Finally, type: tcp stop; tcp start     this will stop and start all tcp services on the server. You should see named start. It takes about a minute for routes to be established. This should do the trick. (I hope)
Get an unlimited membership to EE for less than $4 a week.
Unlimited question asking, solutions, articles and more.
ASKER
psiess

Sorry to have been so long with this.  I have not had an opportunity to try your solution.  I'll let you know when we get a chance to try this.
ASKER
psiess

OK...I made the changes you suggested and still have the same problem.  

I can ping any hosts within my network.  I still cannot ping to the outside.  DNS lookups are working.  As near as I can tell, packets are finding their way out of the network, but can't find their way back in.

Any more clues?
dgrimes

I noticed that my answer was accepted, however most likely it was accepted by the system due time constraints. If you would like more help, you can email me at dgrimes@scvl.com. I'm sure your problem can be itentified fairly easy. Feel free to contact me off the list using my email address.

Have Fun
Dean
Experts Exchange has (a) saved my job multiple times, (b) saved me hours, days, and even weeks of work, and often (c) makes me look like a superhero! This place is MAGIC!
Walt Forbes