• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 202
  • Last Modified:

win32: Curious about the A: drive

Whenever I do
where some_cmd is a dos cmd located remotely on a network; my computer always accesses the a: drive.

This seriously slows down the perl scripts I am trying to run.

I suspect it is something to do with my Windoze platform - I'm running Win98.
I've tried different ports of perl, and checked my system paths for inclusion of a:\.

I've also noticed this behaviour on other windoze machines, so it's not just my computer.

The only way I've managed to get round the a:\ drive access is to get perl to dynamically generate a local batch file (which invokes the some_cmd) and then use system() to run the batch file - still very slow, though.

Any ideas of how to stop my computers curiosity for the contents of my a: drive?
1 Solution
I find that all of the windows platforms will scan the a:\ drive when explorer or a dos window was closed while A:\ was the last selected drive.  You may want to try a chdir in the script.  IE:


It is something you may wish to try.
The book "Windows Annoyances", O'Riley and Associates, discusses this.  It is a bug in McAfee, disable the virus scanner and you will be fine.  The virus scanner is scanning the boot sector of the floppy every time a new process is created.

Horrible isn't it.

And more people complain about Microsoft than McAfee.
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Free Tool: Path Explorer

An intuitive utility to help find the CSS path to UI elements on a webpage. These paths are used frequently in a variety of front-end development and QA automation tasks.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now