Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

Importing Paradox Tables

Posted on 1999-09-10
17
Medium Priority
?
1,053 Views
Last Modified: 2008-02-26
Hi,

Im trying to import some old tables into Access. However Im getting Error 3220, "You tried to link a Paradox table that was created with an international sort order that isn't the same as the one you are using."

Anyone came across this before? Ideas how to solve it? Shall I dig out Paradox? :(

threeps
0
Comment
Question by:threeps99
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 7
  • 6
  • 2
  • +2
17 Comments
 
LVL 4

Author Comment

by:threeps99
ID: 2037032
Edited text of question.
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2037121
threeps,

Go to Tools > Options and on the General tab look at New Database Sort Order.  Try setting it to either General or some other specific order until you get the import to work.

lmerrell
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2037133
Here's a note I just found in help:

Note:   To reset the sort order for an existing database to the language you selected on the General tab, compact that database.

lmerrell
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 4

Author Comment

by:threeps99
ID: 2037155
Imerrell,

Just tried most of them (arabic etc) and still no luck. ARGH!
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2037176
Watch, it'll probably be the last one you try, if it works at all.  Keep tryin'.  I want your points!  ;-)  Wouldn't that just be a bummer. ;-)

lmerrell
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2037213
Looking at "CollatingOrder Property" in help it appears that you have to Compact or create your database with the selected order before that sort order will take affect.  I don't think that just selecting the order then simply trying the import again will work.  Try compacting with some of the different choices.

lmerrell
0
 
LVL 4

Author Comment

by:threeps99
ID: 2037229
Immerrell if you can solve this for me you are most welcome to the points.

It does have an apply button once you have made your changes, I dont understand why this would happen.

threeps
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2037305
By just "applying" the new sort order it doesn't take effect.  Remember the note from earlier:

Note:   To reset the sort order for an existing database to the language you selected on the General tab, compact that database.

You have to actually compact before trying the import each time.  I don't know if this means anything but in Help for "CollatingOrder Property" it calls Norwegian or Danish and Swedish or Finnish Paradox orders.

lmerrell
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2037675
threeps,

Any luck with the changing order, compacting and importing, yet?

lmerrell
0
 
LVL 4

Author Comment

by:threeps99
ID: 2037872
Nope, and sorry, this will have to wait until Monday...... have a good weekend.

threeps
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2037911
Same to you threeps.  Have a good one!
0
 
LVL 3

Expert Comment

by:tcurtin
ID: 2038594
Export the Paradox tables to a dBase format then import. I've had problems with paradox and that always seems to work. I don't know if you are out of the states or if the pdx or .mdb is international.
0
 
LVL 4

Author Comment

by:threeps99
ID: 2039383
Sorry but I dont want to have to go back to Paradox to solve this (if I can help it) I want to solve it from Access.
0
 
LVL 1

Expert Comment

by:MickeyB
ID: 2040967
I came across a similar difficultly linking Paradox 3.0 databases to Access 1.0 many years back.

It was all to do with the settings for "CollatingSequence" for the Paradox ISAM in the msaccess.ini file

From memory the default setting was "Ascii" and to link to the Paradox tables I was using it had to be changed to "International"

Looking through the Access 97 help files under "Initializing the Paradox Database Driver"
there are similar settings for the Paradox ISAM in the registry.

Access help says the "CollatingSequence" entry must match the collating sequence used when the Paradox table was built.

Look in the "Jet\3.5\Engines\Paradox" folder in the registry and try changing the "CollatingSequence" to "International" or one of the other two values shown in Access help.

I have not been able to try this myself with Access 97 but I do know it worked with Access up to version 2.0 and with Visual Basic 3.0.


0
 
LVL 4

Author Comment

by:threeps99
ID: 2041528
MickeyB,

That solved it thanks. I went into the registry and changed the colating sequence from Ascii to International and it worked fine! Post for points.

thanks everyone

threeps
0
 
LVL 1

Accepted Solution

by:
MickeyB earned 800 total points
ID: 2041561
See text below
0
 
LVL 1

Expert Comment

by:Moondancer
ID: 6868417
This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed, along with the link to All Topics which reflects many TAs recently added.

http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
http://www.experts-exchange.com/jsp/zonesAll.jsp
 
Thank you,
Moondancer
Moderator @ Experts Exchange
0

Featured Post

Technology Partners: We Want Your Opinion!

We value your feedback.

Take our survey and automatically be enter to win anyone of the following:
Yeti Cooler, Amazon eGift Card, and Movie eGift Card!

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

As tax season makes its return, so does the increase in cyber crime and tax refund phishing that comes with it
Instead of error trapping or hard-coding for non-updateable fields when using QODBC, let VBA automatically disable them when forms open. This way, users can view but not change the data. Part 1 explained how to use schema tables to do this. Part 2 h…
In Microsoft Access, learn the trick to repeating sub-report headings at the top of each page. The problem with sub-reports and headings: Add a dummy group to the sub report using the expression =1: Set the “Repeat Section” property of the dummy…
With Microsoft Access, learn how to specify relationships between tables and set various options on the relationship. Add the tables: Create the relationship: Decide if you’re going to set referential integrity: Decide if you want cascade upda…

715 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question