PPP Support for kernel under slackware

Could someone give me location to download kernel with
PPP Support for slackware ?

I Have slackware version 4.0 and when I execute "pppd" it
tells me that my kernel doesn't support ppp or not loaded
to the kernel module.
Who is Participating?
cananiConnect With a Mentor Commented:
First, read the Linux Kernel HOWTO to learn how to customize the Linux kernel.


Second, assuming you've installed the kernel source,
'cd /usr/src/linux' and run 'make menuconfig'. When the configurations menu appear, enter 'Network Devices' option and select 'PPP'.

Third, compile and install the new kernel according to the instructions contained in the URL above.
I believe you will find that this requires that you recompile the kernel rather than download something more.  In other words, the ppp support you are looking for is already on your hard drive, but not yet part of the kernel. Most linux books have instructions for this and I believe there are "Howto's" but if you don't know how to start to recompile, someone will answer you in this forum.
You might also want to run 'make mrproper' before you run 'make menuconfig' ... after you finish with the menuconfig options you will want to run 'make dep' and 'make clean' before you run 'make zImage.'  then you can move your old kenel out of the way in the "/" directory with 'mv vmlinuz vmlinuz.old' and then bring in the new kernel with 'cp /usr/src/linux/arch/i386/boot/zImage /'

Then, if you are using LILO, you should use a text editor to change the /etc/lilo.conf file -- get rid of "image=/vmlinuz and replace it with "image=/zImage"

RElax.  It sounds harder than it really is.
I wouldn't actually move the original /vmlinuz file. If something goes wrong with the new kernel, your Linux wouldn't boot anymore !!!

After you 'cp /usr/src/linux/arch/i386/boot/zImage /' ,
edit /etc/lilo.conf and insert another entry for the new kernel. It should look like:

# Start LILO global section
boot = /dev/hda
delay = 50
vga = extended
ramdisk = 0      # paranoia setting
# End LILO global section

# Linux bootable partition config begins
image = /zImage
  root = /dev/hda1
  label = linux
only for checking
image = /vmlinuz
  root = /dev/hda1
  label = linuxold
# Linux bootable partition config ends

Good Luck

This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed, along with the link to All Topics which reflects many TAs recently added.


In efforts to help all Members maintain their open questions, this is a reminder to click your Member Profile, expand your question history and find/update all your Open and Locked questions.
Thank you,
Moderator @ Experts Exchange
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

All Courses

From novice to tech pro — start learning today.