• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 2872
  • Last Modified:

HELP! System cannot open COM Port

 
     I am running Windows NT 4.0 with SP5.  It is a relatively new install.  However, when I finally got around to using my modem, I ran into a particular problem.  Certain programs could use my modem fine, such as Network Dial-Up, Hyperterminal, Winfax Pro.  But other programs, like Telix, or Searchlight BBS (I tried both the DOS, and the 32bit Windows version) would generate the following error:

     "The system cannot open COM1 port requested by the       application"  and it gave me the option to Terminate       or Ignore.

     I have used these very same programs in the past with the same version of NT, without a problem.  I tried reinstalling NT and attempting the programs both before and after I patched it with no success.  Does anyone know what causes this, and how I can correct it?  Thanks!


                                                               Ocean
0
Ocean
Asked:
Ocean
1 Solution
 
gothickCommented:
That error message would normally indicate that the COM1 port is already in use by another application.  Does it do that if the offending program is the first thing you run after a re-boot?
0
 
benstockCommented:
Stop the RAS Services and see if that helps you ti run the other apps.
0
 
ddmorganCommented:
first check all of your serial port options in control panel... but remember that NT does not like for apps to interact with the hardware above it's self,, after checking and verifing the port settings check all services that are running and make sure they do not have the com ports tied up..
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

 
sargon99Commented:
take benstops answer and disable RAS that has fixed that problem for me several times.
0
 
Jason_SCommented:
What other COM ports are on the system?  More specificaly, do you have a device using COM3?  If so, it is probably attempting to share IRQ4, thus causing the problem.  Some software, and hardware have problems with sharing resources.  You could move the modem to COM 2, and give that a try.
0
 
OceanAuthor Commented:

     Thank you!  Thank you all for your help.  One of the suggestions did it.  Stopping the RAS service fixed the issue.  My remaining question is this:  What *exactly* does RAS handle?  I need to know what the possible consequences are of my disabling this service.  I do dial out to an ISP, and I do use other Windows telecommunication programs like WinFax Pro.  

     Thank you again for your help!



                                                     ocean
0
 
benstockCommented:
I'll post as answer as I was the first to suggest.
And the RAS Service will deal withh incoming dial up requests.  Set the service to Manual startup and you should suffer no ill effects.
0
 
MoondancerCommented:
This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed, along with the link to All Topics which reflects many TAs recently added.

http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
http://www.experts-exchange.com/jsp/zonesAll.jsp
 
Thank you,
Moondancer
Moderator @ Experts Exchange
0
Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

Featured Post

Cloud Class® Course: Microsoft Azure 2017

Azure has a changed a lot since it was originally introduce by adding new services and features. Do you know everything you need to about Azure? This course will teach you about the Azure App Service, monitoring and application insights, DevOps, and Team Services.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now