Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

"Incorrect collating sequence" importing Paradox table

Posted on 1999-10-12
23
Medium Priority
?
2,824 Views
Last Modified: 2008-02-20
I am trying to import a Paradox table (that I know very little about) and when I do I get a message that says: "Incorrect collating sequence" with OK and Help.  Click on help and it says: "Incorrect collating sequence. (Error 3220)
You tried to link a Paradox table that was created with an international sort order that isn't the same as the one you are using."
What the heck does that mean?  And how can I fix it?  Or can I?
0
Comment
Question by:Thorin
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 5
  • 5
  • 4
  • +5
23 Comments
 
LVL 4

Expert Comment

by:MacRena
ID: 2121170
Thorin,
In the receiving Access database, go to TOOLS/OPTIONS and select GENERAL tab, you will see a drop-down box containing the available International Sort Orders.
You need to match the language with that of the Incomming Table.
That's all I know, sorry, I don't know Paradox either.
Good Luck,
Mac
0
 
LVL 2

Author Comment

by:Thorin
ID: 2121292
Well...I tried that...I changed it to all of the options and then tried importing after each one - no luck.  Same error.  I am pretty sure that it is an English speaking type of file...came out of an English version of a database program.  Any other suggestions?  Anyone?
0
 
LVL 1

Expert Comment

by:enite
ID: 2121319
I seem  to recall that particular error occurs when the pdox file is saved in a collated order different from the one on the user's machine.  

There is a registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Paradox\CollatingSequence

Where you can specify the collating order.  I know one of the permissible values is "Ascii" -- I don't know the exact value of the other -- something like  - international - don't quote.  If this key in your registry is NOT "Ascii" you may want to try changing that value first.  

Good Luck
0
Use Case: Protecting a Hybrid Cloud Infrastructure

Microsoft Azure is rapidly becoming the norm in dynamic IT environments. This document describes the challenges that organizations face when protecting data in a hybrid cloud IT environment and presents a use case to demonstrate how Acronis Backup protects all data.

 
LVL 4

Expert Comment

by:threeps99
ID: 2121345
Yes enite has it, I came across this problem before

http://www.experts-exchange.com/jsp/qShow.jsp?ta=msaccess&qid=10204570 

Deja Vue!

Let me know if that question solves it or you need more help?

threeps
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2121364
Thorin, the following is from an earlier question with the same problem:

It was all to do with the settings for "CollatingSequence" for the Paradox ISAM in the msaccess.ini file

From memory the default setting was "Ascii" and to link to the Paradox tables I was using it had to be changed to "International"

Looking through the Access 97 help files under "Initializing the Paradox Database Driver" there are similar settings for the Paradox ISAM in the registry.

Access help says the "CollatingSequence" entry must match the collating sequence used when the Paradox table was built.

Look in the "Jet\3.5\Engines\Paradox" folder in the registry and try changing the "CollatingSequence" to "International" or one of the other two values shown in Access help.

Hope this helps.

lmerrell
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2121368
Hi, threeps, same question - yours!  Above is the text from the answer.  Come on threeps, #15 is all your's.  ;-)
0
 
LVL 4

Expert Comment

by:threeps99
ID: 2121370
At my question on this, just ignore Immerrels ramblings it was a very techy time for the two of us, we both had point troubles :)

threeps
0
 
LVL 4

Expert Comment

by:threeps99
ID: 2121372
GOt ya Immerrell :)
0
 
LVL 2

Author Comment

by:Thorin
ID: 2121388
Well...that fixed it.  Don't I feel like a dumbsh.. for not doing a little searching before asking.  Anyway, I am not sure who deserves the points on this one - you guys work it out, and then somebody post an answer!

Thanks!
0
 
LVL 4

Expert Comment

by:threeps99
ID: 2121403
Oh well done, thats like dropping a steak in a lions cage. ;p

I dont know.....

threeps
0
 
LVL 2

Author Comment

by:Thorin
ID: 2121430
Well...it sort of looks like Enite should get them as that was the person with the first notice of the answer.  

Agreed?
0
 
LVL 1

Expert Comment

by:MickeyB
ID: 2121767
Am I entitled to a royalty if my answer from http://www.experts-exchange.com/jsp/qShow.jsp?ta=msaccess&qid=10204570 
is used again?  ;-)
0
 
LVL 12

Expert Comment

by:Trygve
ID: 2122226
enite has the answer.

This problems also occurs when I have been "working" on database received from people in other countries, without any paradox tables in them. I think the problem is related to differences in the sorting order settings in Access itself. Perhaps differences in local version?

The solution is
1) Enter RegEdit
2) Locate Jet\3.5\Engines\Paradox
3) Look at the key "CollatingSequence"
4) If ascii, change it to international, if international change it to ascii
5) Restart

Works every time, but is really irritating when you are in the middle of a project and have to close down 71 programs and wait for the computer to restart.
0
 
LVL 1

Accepted Solution

by:
enite earned 800 total points
ID: 2123345
I seem  to recall that particular error occurs when the pdox file is saved in a collated order different from the one on the user's machine.  

There is a registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Jet\3.5\Engines\Paradox\CollatingSequence

Where you can specify the collating order.  I know one of the permissible values is "Ascii" -- I don't know the exact value of the other -- something like  - international - don't quote.  If this key in your registry is NOT "Ascii" you may want to try changing that value first.  

Good Luck
0
 
LVL 12

Expert Comment

by:Trygve
ID: 2123566
enite: That is an exact copy of my comment. Bad boy !!! :-(
0
 
LVL 12

Expert Comment

by:Trygve
ID: 2123829
Thorin: Why did you accept the answer when it was a copy of a previous posted comment?
0
 
LVL 2

Author Comment

by:Thorin
ID: 2123892
Huh?  Your comment came in 9 hours after Enite had posted the same thing you said in an earlier comment.  Enite's answer was just a reiteration of what he had said earlier so that I could give him the points he deserved.  Perhaps he didn't have as much detail as you did, but I was able to fix my problem with the information he gave - and so I feel he should get the points.  You even said "Enite has the answer" in your comment...I appreciate your help, but you were a little late.

-Thorin
0
 
LVL 12

Expert Comment

by:Trygve
ID: 2124014
I am very sorry (crawling in the dust chewing those sandcorns...)

I confused this question with another.

Agai;, very very very sorry...
0
 
LVL 2

Author Comment

by:Thorin
ID: 2124051
Well...that was probably my fault for not doing a little looking before posting - and ending up posting the exact same question someone else had posted a few days ago...

Live and learn right?
0
 
LVL 7

Expert Comment

by:lmerrell
ID: 2124085
Trygve - You've been working too hard.  Time for a holiday!  ;-)
0
 
LVL 4

Expert Comment

by:MacRena
ID: 2124121
lmerrell,
do you think Trygiv is feeling the heat? - brewdog has closed in to only 90,000 points behind! - Practically breathing down his neck! :>)
0
 
LVL 12

Expert Comment

by:Trygve
ID: 2124125
Thorin: Right!

lmerrell: I think the problem is that I have tried to do some efficiency improvements on my time at EE. I guess that I am not quiet there yet :-)

See you...
0
 
LVL 1

Expert Comment

by:Moondancer
ID: 6852646
This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed, along with the link to All Topics which reflects many TAs recently added.

http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
http://www.experts-exchange.com/jsp/zonesAll.jsp

Check Community Support if you're an expert interested in the Abandoned Q Cleanup Effort.
 
Thank you,
Moondancer
Moderator @ Experts Exchange
0

Featured Post

What does it mean to be "Always On"?

Is your cloud always on? With an Always On cloud you won't have to worry about downtime for maintenance or software application code updates, ensuring that your bottom line isn't affected.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

In earlier versions of Windows (XP and before), you could drag a database to the taskbar, where it would appear as a taskbar icon to open that database.  This article shows how to recreate this functionality in Windows 7 through 10.
AutoNumbers should increment automatically, without duplicates.  But sometimes something goes wrong, and the next AutoNumber value is a duplicate.  This article shows how to recover from this problem.
In Microsoft Access, learn the trick to repeating sub-report headings at the top of each page. The problem with sub-reports and headings: Add a dummy group to the sub report using the expression =1: Set the “Repeat Section” property of the dummy…
With Microsoft Access, learn how to specify relationships between tables and set various options on the relationship. Add the tables: Create the relationship: Decide if you’re going to set referential integrity: Decide if you want cascade upda…

704 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question