Still celebrating National IT Professionals Day with 3 months of free Premium Membership. Use Code ITDAY17

x
?
Solved

IDE/ATAPI CD-ROM fail under 2.2.0 and higher

Posted on 1999-10-21
9
Medium Priority
?
237 Views
Last Modified: 2010-04-20
I have an IDE/ATAPI cdrom (ACER 8x) which doesn't work on kernels 2.2.0 and higher.

On kernel 2.0.35 it runs well:
hda: QUANTUM FIREBALL ...
hdc: no response, resetting
hdc: CD-ROM ...

BUT on kernel 2.2.0+ the following happens:
hda: QUANTUM FIREBALL ...
-- 5 seconds the computer is waiting ---
AND countinues booting without any CD-ROM detected.

I know, that there must exist a compilation of kernel 2.2.x that works, because the installation of Su.S.E 6 is also built on kernel 2.2.0.
BUT no publicated version worked.

Please give me an advise, what to do.
Thanks

aegressy


Note: Maybe there will be something on 'no response, resetting' - but I don't know what.
0
Comment
Question by:aegressy
[X]
Welcome to Experts Exchange

Add your voice to the tech community where 5M+ people just like you are talking about what matters.

  • Help others & share knowledge
  • Earn cash & points
  • Learn & ask questions
  • 3
  • 3
  • 2
  • +1
9 Comments
 

Expert Comment

by:clayj
ID: 2147132
This really looks like a hardware issue.  When you 1st turn on your machine, what does the BIOS recognize, and where (Primary or Secondary controller, Master or Slave)?

I've seen this happen when a drive was jumpered as a SLAVE and there was no MASTER drive present on that controller.

If that's the case, then you'll want to either put the CDROM on the 2nd port of the PRIMARY controller; or re-jumper the CDROM to be a MASTER on the SECONDARY controller.

0
 

Author Comment

by:aegressy
ID: 2164174
I have the Quantum disk on Primaty-Master and the CD-ROM on Secondary-Master. And I have no other devices on the controller.

I will check it again, but it must be jumpered well - by my opinion - cause otherwise it wouldn't work in Windowzes or on an older kernel.
0
 

Expert Comment

by:clayj
ID: 2164647
Not neccessarily; the "no response" message under 2.0.35 says that SOMETHING is still wrong there.  

When you first boot, what does your BIOS say it recognizes?
0
Ransomware-A Revenue Bonanza for Service Providers

Ransomware – malware that gets on your customers’ computers, encrypts their data, and extorts a hefty ransom for the decryption keys – is a surging new threat.  The purpose of this eBook is to educate the reader about ransomware attacks.

 
LVL 1

Expert Comment

by:Barn_Owl
ID: 2201027
Clay is right. Windoze is much more passive about bad hardware. I have a cdrom doing just the opposite right now works under linux but not win. You can alos try tapping the eject button during the scan to wake up a "sleepy " drive.
0
 

Author Comment

by:aegressy
ID: 2201395
So first the BIOS at first boot-up:
   Found ATAPI CDROM 685A-(SM)
(SM) - means on Secondary Master.

And one more note: It happened two times, that the CD-ROM worked under the mentioned kernel. Once I was openning the CD's door right at the time, when Linux was initializing the IDE-controller, but I tried it at least 20 times, and it did not help. At the second time, it was after using Windoze. But I also tried this - with Win drivers, with DOS drivers, restarting, resetting, restarting from DOS mode ... And the result: still nothing.
0
 

Expert Comment

by:clayj
ID: 2201821
I still think you need to check the device itself (I know it's a pain to pull it out; I've been through exactly this problem).  On my CD (it's a "generic" brand I got at a discount store), there were TWO jumpers - for MASTER, one of them was not connected, and the other was jumpered across 1-2 (of 6).  For SLAVE, 3-4 and 5-6 were BOTH jumpered.  It's possible that you've got that sort of a problem.  Also, the "hdc - no response, resetting" message indicates that there REALLY IS a problem; but for some reason the earlier kernel recovers.  I would expect that if you get rid of that problem, the problem with 2.2 will go away as well.

Have you tried jumpering the CD as a SLAVE and running it off the PRIMARY interface?

Clay
0
 

Author Comment

by:aegressy
ID: 2236310
Something very special happened:

When I put the CD-ROM to the same cable, as the HDD, it WORKED.

But if I have the CD and the HDD on the same cable, the HDD is SLOW (and it is not a good thing).

AND I tried all the possibly situations with the jumpers (on the CD), and I also tried to exchangle the IDE cables.
The result is the same: with the HDD it works, whithout it doesn't work.

Very, very unusual.

Where is the problem? Not known.
0
 
LVL 1

Expert Comment

by:Barn_Owl
ID: 2236572
I have seen similiar problems with hardrives that have had there controller go bad on them. This means two things, one you have a really good hdd and second is that your cdrom likly bad or rapidlly failing.
0
 
LVL 1

Accepted Solution

by:
patowic earned 300 total points
ID: 2287786
kernel 2.2.0 is....interesting, to say the least.  I'd recommend downloading kernel 2.2.13, and compiling ATAPI cdrom support into the kernel, then rebooting.  If that doesn't work, let me know--there may be specific arguments we have to pass to lilo to get it to recognize the cdrom.

If it makes you feel any better, I had all sorts of interesting problems with kernel 2.2.0

2.2.13, on the other hand, is quite stable, and supports lots of hardware.

Jeremy
0

Featured Post

How to Use the Help Bell

Need to boost the visibility of your question for solutions? Use the Experts Exchange Help Bell to confirm priority levels and contact subject-matter experts for question attention.  Check out this how-to article for more information.

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

If you have a server on collocation with the super-fast CPU, that doesn't mean that you get it running at full power. Here is a preamble. When doing inventory of Linux servers, that I'm administering, I've found that some of them are running on l…
Using 'screen' for session sharing, The Simple Edition Step 1: user starts session with command: screen Step 2: other user (logged in with same user account) connects with command: screen -x Done. Both users are connected to the same CLI sessio…
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.
How to Install VMware Tools in Red Hat Enterprise Linux 6.4 (RHEL 6.4) Step-by-Step Tutorial
Suggested Courses

664 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question