MS Proxy 2.0 ftp problem

I am using Microsoft Proxy server version 2.0 to
provide LAN clients on our private network to
access the internet. The proxy server proxies http and ftp.
The problem is that when trying to access an ftp site
using internet explorer 5.0 ( IE5 ) such as
ftp://ftp.microsoft.com , a warning message
is displayed by IE5 which says that access is limited
to read only due to proxy server configuration.
I imagine that there is a registry entry somewhere in our
Proxy server for MS Proxy server 2.0 which will allow full
rights to the target server ( subject to the target servers
configuration ). I realise that the example given above refers
to a server that will not allow write access but we get the same
problem on other servers where write access IS allowed.

Hope someonme can help ?
LVL 2
Roger AlcindorAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jbuntingCommented:
PSS ID Number: Q199376
Article last modified on 04-29-1999
 
WINDOWS:5
 
WINDOWS
 

======================================================================
-------------------------------------------------------------------------------
The information in this article applies to:
 
 - Microsoft Internet Explorer version 5 for Windows 95
 - Microsoft Internet Explorer version 5 for Windows 98
 - Microsoft Internet Explorer version 5 for Windows NT 4.0
-------------------------------------------------------------------------------
 
SYMPTOMS
========
 
When you use Internet Explorer to connect to an FTP site, you may receive the
following warning message:
 
   FTP Proxy Warning
 
   The folder 'fpt://ftp.<site.name>/' is read-only because the proxy
   server is not set up to allow full access.
 
   To move, paste, rename, or delete files, you must use a different proxy. For
   information on changing your proxy, contact your administrator.
 
CAUSE
=====
 
This issue can occur if any of the following conditions are true:
 
 - Browsing Enhancements are not enabled in Internet Explorer.
 
 - You are using a CERN style proxy server that turns off the FTP service. For
   example, Microsoft Proxy Server 2.0 is a CERN style proxy server.
 
 - You do not have write or delete permissions on the FTP server.
 
RESOLUTION
==========
 
To resolve this issue, disable the Web-based FTP option. To do this, follow
these steps:
 
1. Click Start, point to Settings, and then click Control Panel.
 
2. Double-click Internet Options.
 
3. On the Advanced tab, click to clear the Use Web Based FTP check box, and then
   click OK.
 
Additional query words:
 
======================================================================
Keywords          : kbenv kberrmsg kbnetwork msiew95 msient msiew98
Version           : WINDOWS:5
Platform          : WINDOWS
Issue type        : kbprb
=============================================================================
Copyright Microsoft Corporation 1999.


 
0
Roger AlcindorAuthor Commented:
It is by no means clear how the matter can be resolved by disabling the Web-based FTP option because THE PROXY SERVER IS NOT OUR DEFAULT GATEWAY. IE5 on each machine is set to use the proxy server but if, as is suggested, the web based ftp option is disabled ( and I'm assuming that this refers to IE5 on a client PC and not the proxy server ?  ), how will the ftp session find its way to the proxy server ?
If you can clarify or expand on this matter ( ie. specifically state whether or not we can use MS proxy server 2.0 in this situation ), the points are yours. Re-configuring our world-wide WAN is not an option. Could you recommend a more suitable proxy server perhaps ?

Thanks - Roger

0
jbuntingCommented:
You'll need to use the winsock proxy client instead of the web proxy.  The install for this should be in an \mspclnt share on the proxy server.  MS Web Proxy doesn't allow you to set any permissions except FTP read.
This might not be a good solution in your case if you have a large WAN.  Sorry, I'm not familiar enough with any other proxy servers to recommend them in a large-scale environment.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows Networking

From novice to tech pro — start learning today.