3c509b Detection Problems

I have a 3com 3c509b running in PnP mode and I can't figure out how to get the module to work I load it with the command insmod 3c509.o it installs it my cable modem blinks but I still can't get on the net. I've tried recompiling a new kernel with built in support but I can never get the new kernel to work. I run redhat 6.1 and it won't even detect it when I turn off PnP mode. Or is there a new driver I can get because the ones on the 3com webpage for linux don't work with redhat 6.1.

Some one has gotta get this question it's been pissing me off for a month now:)
Grifter50Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ihardingCommented:
One suggestion would be to check in your PC's bios and see if the resources are updated, ie, is your BIOS reporting the right resources to Linux?  On most PNP BIOSes, there is a setting to update the PNP info.  That is where I would start.

I run that card on one of my home machines, and use the module that comes built into RH 6.1 and it works fine.  You might also want to check your eth0 settings to make sure they use the right module.
0
adam923Commented:
i've had some problems with my 3c509b in redhat 6.1 too
my solution was to make sure the kernel modules control panel does NOT specify an io port parameter.  this seems to screw it all up when an io port address is present.  let me know if this helps you.
0
Grifter50Author Commented:
adam923's answer worked half way but when it's trying to initilize the eth0 interface it fails because it can't determine the IP stuff. Any ideas?
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

adam923Commented:
have you entered all of your ip information in the network control panel and set the eth0 to active on bootup
i'm dual boot and in windows now so i can't be very specific
0
Grifter50Author Commented:
I ran winipcfg and it has an entry called dhcp server do you know what that is called in linux? Also my IP changes every once and a while do I put it on static IP?
0
Grifter50Author Commented:
can you also walk me through what everthing is in the network configuration?
0
adam923Commented:
dhcp is the program that gives you dynamic ip's
i'll boot into linux this afternoon and give you the step-by-step instructions
0
adam923Commented:
ok, open the network configuration tool from control panel
on the first tab "Names" your hostname should be whatever you want to call your computer
your domain should be provided by your isp (most likely ispname.com)
search domains can be blank
name servers should be provided by isp (numeric ip form), enter one ip address per line
skip to the third tab "interfaces". delete any entries besides the loopback (interface lo) and then click add  choose ethernet as the type and click ok
in the next window check "activate at boot time" and change the interface config protocol to DHCP,
click done and then save.  the new interface should now be in the list and named "eth0"
on the second tab "Hosts"
remove whatever you already have there, but leave the loopback entry (ip 127.0.0.1)
on the fourth tab "routing"  make sure packet forwarding is off  enter the ip address of the default gateway as provided by your isp and for the gateway device enter the interface name - most likely "eth0" (don't enter quotes)  the routing table below should be blank
click save and then quit below
now go to your kernel control panel and verify that device eth0 exists and its module is 3c509 and it has NO base i/o address specified
close this control panel and reboot
let me know if you have questions
0
Grifter50Author Commented:
I did everything that you suggested but the eth0 interface is still unable to determine the IP information. It wouldn't be because I have linux installed on another hard drive would it?
0
adam923Commented:
that wouldn't seem likely.  please give the exact wording and context of the error message.  if you type lsmod is 3c509 there? if you type ifconfig is eth0 there?
0
Grifter50Author Commented:
yeah both the lsmod for 3c509 and the ifconfig were there so I have no idea what is wrong.
0
adam923Commented:
can you post the output from ifconfig?  make sure it's giving you info for the interface eth0 and no just the interface lo
0
Grifter50Author Commented:
the ifconfig eth0 command prints off the following screen:

Link encap: ethernet HWaddr 00:10:5A:CD:85:FD
Broadcast MTU:1500 Metric:1
RX Packets:0 errors:0 dropped:0 overruns:0 frame:0
TX Packets:10 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
Interupt:10 Base Adress: 0x300
 
thats what it says and I have no idea what it all means
0
adam923Commented:
ifconfig should also report your internet address (ip number)  this indicates a DHCP problem.  is the computer dual-boot? and if so does the dhcp work in windows?  can you confirm with your isp the details of setting up the network protocols? (even if you have to get them to explain it in windows terms and then post here for a linux translation if possible)
also- try a ping test although this seems bound to fail if the card doesn't know its ip address
ping 127.0.0.1
ping (isp's nameserver 1)
ping (isp's nameserver 2)
0
Grifter50Author Commented:
Yes the computer is dual-boot and my internet works fine in windows, I have emailed my isp before and got all the network info but it didn't really help me much.
0
adam923Commented:
so you have dhcp enabled in windows and it works fine?
i guess all i can say is go back over the linux network configuration and make sure its set to dhcp... there aren't really any options for dhcp to check.
0
Grifter50Author Commented:
are there any packages that I should have installed?
0
adam923Commented:
not that i know of... just for a test try writing down your dynamic ip address from windows (run winipcfg to get it) and using it as a static ip (turn DHCP off) in linux
0
Grifter50Author Commented:
Here's what happened I rebooted into Linux and it was able to initilize interface eth0 at bootup but it paused for long periods when It was loading up the system logger, sendmail and when I started up X it took like 10 minutes and it got to a screen that said tying to determine ip information but failed, any ideas
0
adam923Commented:
ok, i think you've finally stumped me
0
Grifter50Author Commented:
Let me know if you think of anything else
0
adam923Commented:
i've never used dhcp in linux before so i'll defer to another source
http://www.linux-howto.com/LDP/HOWTO/mini/DHCP.html
let me know how it goes or if you have any questions about interpreting this document
0
Grifter50Author Commented:
Heres what happened I changed my interface protocal from dhcp to none and now the eth0 interface loads up ok at bootup when I type in ifconfig I get an ip adress but I loaded up netscape and it takes forever to find a website, any ideas
0
adam923Commented:
what takes a long time? a. the name resolution b. the server's response or c. the file downloads
to test for (a) try comparing http://www.yahoo.com to http://204.71.200.75
also, be aware that it's not such a great idea to depend on this work-around of using a static ip when the server expects you to have a dynamic one.  one way to ensure that you always have that ip is renew it regularly by running windows.  how regularly you'll need to do this depends on how long the lease lasts.  usually the dhcp client will try to renew it's lease when it's halfway to the expiration date.  you can manually renew with the winipcfg program
0
Grifter50Author Commented:
what is a static ip and a dynamic one and how can I fix something thats wrong with my DNS servers (name servers)?
0
adam923Commented:
part a:
static ip - an address for your computer that you type in, it doesn't change
dynamic ip - an address that a server gives you using DHCP, it can change
part b:
let me know if there is something wrong with your dns and then we'll talk about it.
0
Grifter50Author Commented:
Well windows uses DHCP but when I use it as my eth0 interface protocal it won't load up at bootup time, it makes no sense I have no idea whats wrong.
0
adam923Commented:
but when you turned dhcp off and typed in an ip address it worked ok (even though it might have been slow)?
0
Grifter50Author Commented:
Nope the net has never worked I've never been able to load up a webpage yet, I've tried winlinux and thats worked fine because it auto detected my card so i'm wondering if it's not my card.
0
adam923Commented:
it's not your card b/c your card works in windows
i'm not sure what else i can tell you for this one, it would seem that your card and module in linux work just fine but the dhcp doesn't work... maybe post another question?
0
Grifter50Author Commented:
Ok well lock the question and I'll give you the points you deserve it for helping me out this much
0
adam923Commented:
thanks
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.