Running a PERL CGI script in NETSCAPE ENTERPRISE SERVER in Win NT

I have set up a Netscape Enterpriser Server 3.5.1 based site on a Windows NT system. I've installed Perl for Win32 to run CGI scripts. I have the CGI scripts named with extension .pl. I have associated the extension to perl executable thru winfile and with options/new type in explorer .
I have put a cgi script in folder c:\web\cgi-bin\ and made it the CGI directory in NES' Settings (also tried making the folder as WINCGI folder, SHELLCGI folder etc).

On making a request, to the CGI script thru a browser client to the server, it is not working.

I get the following error msg.

When perl file is made CGI pgs thru CGI directory :

Message sent to the client browser:
-----------------------------------
Server Error

This server has encountered an internal error which prevents it from fulfilling your request. The most likely
cause is a misconfiguration. Please ask the administrator to look for messages in the server's error log.

Message seen in the  error log of NES.
---------------------------------------
[28/Oct/1999:18:18:12] failure: for host 192.168.191.177 trying to GET /cgi-bin/test.perl, send-cgi reports: could not send new process (Error Number is unknown)
[28/Oct/1999:18:18:12] failure: cgi_send:cgi_start_exec c:\web\cgi-bin\test.perl failed

 
However, the same script when run on the UNIX version of NETSCAPE ENTERPRISE SERVER, it works without any problem.
 
It would be helpful,iIf anyone can provide me an answer.

Thanx

Vetri
vetriAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

vetriAuthor Commented:
Edited text of question.
0
samikCommented:
You said you have associated .pl to perl scripts, but your error logs show that you were trying to run the script as test.perl (not test.pl). Would a simple rename correct the problem?

In Unix, the program runs with any filename extension if you have correct #! line in the beginning of the script.

0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
vetriAuthor Commented:
Hi,

  Actually, I created my CGI with both the extensions .pl and .perl
  To be clear, I named them .pl and associated perl.exe to .pl file extensions once and later named the scripts with .perl extension and associated the extension to perl.exe and tried to execute the CGI script.
  In both the cases, the output of the cgi script failed to be sent to the client by the server.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Scripting Languages

From novice to tech pro — start learning today.