?
Solved

samba password w/ 98

Posted on 1999-10-27
7
Medium Priority
?
270 Views
Last Modified: 2010-03-18
I previously set up a Samba server on a LAN made up of a few
linux boxes and 2 win boxes (98 and NT). I set up samba on one of the linux boxes for file serving to all of the machines.  I am having trouble with the win98 machine, when i goto the network neighborhood and open the partition on the samba server i am prompted for a password, i enter the password for that user's login on the samba server and get an access denied.  I was wondering if this has to do with some sort of password encryption that 98 is trying to do but smaba doesn't support.  
0
Comment
Question by:penguinusr
7 Comments
 
LVL 2

Expert Comment

by:tmoss
ID: 2164369
There is possibly an encryption issue but that would affect the NT machine also. It's more likely a username issue. Does the username you log into the 98 box with exist on the Linux box too?
0
 

Expert Comment

by:Franky_Devos
ID: 2165198
You can also try to use smbpasswd

> smbpasswd -a USERNAME

the -a options adds a passwd to the passwd list of smb.
0
 
LVL 2

Accepted Solution

by:
foxr earned 140 total points
ID: 2166230
One other thing to try is to edit the smb.conf file and make sure that your samba workgroup matches your windows workgroups/domain (not a tcp/ip domain).  This setting is easily changed and occurs near the beginning of the file.  Also, make sure you enter the ip address of the windows machines in the allow access section of the smb.conf file.
0
Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

 

Expert Comment

by:aaronhirsch
ID: 2174895
This is definately an encryption issue.  Ever since 95 OSR2 Window$ has been using encryption on passwords.  You have two options...You can either a) turn on encrypted passwords in your /etc/smb.conf file, not recommended to do until you have read quite a few man pages...they show what all needs to be done.  or b) enable plain text password on the Window$ boxes.  The later is the easiest way to correct this problem, but it does cause a slight security issue.
0
 
LVL 2

Expert Comment

by:foxr
ID: 2174918
There is an NT registry key (see knowledgebase @www.microsft.com) to allow clear text password authentication.  I dont' recall it off the top of my head but it is easy to find, easy to change, and as always with Windows....will require a reboot.
0
 

Expert Comment

by:aaronhirsch
ID: 2174938
True, but will the NT registry key work with Win98?  Since according to the above notes that is what he is experiencing difficulity with.  Dosen't really matter...there is a Win98 registry too...I also do not remember the exact url, but I do have the files if anyone needs them...:}
0
 

Expert Comment

by:stevewarren
ID: 2298316
Both Win98 and WinNT use encrypted passwords.  To see if encryption is the cause add "encrypt passwords = yes" without the quotes to the global section of your smb.conf file and restart the server.


If this doesn't work try "smbadduser <username>:<username>"

example....

smbadduser johndoe:johndoe

As long as johndoe is a valid login name for the Linux box you'll be asked to give johndoe a password.  This password is different than the login password.

If you use the smb username and password as your Windows login you won't be prompted to enter a username/password again to access the samba share.
0

Featured Post

Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

Question has a verified solution.

If you are experiencing a similar issue, please ask a related question

I have seen several blogs and forum entries elsewhere state that because NTFS volumes do not support linux ownership or permissions, they cannot be used for anonymous ftp upload through the vsftpd program.   IT can be done and here's how to get i…
Note: for this to work properly you need to use a Cross-Over network cable. 1. Connect both servers S1 and S2 on the second network slots respectively. Note that you can use the 1st slots but usually these would be occupied by the Service Provide…
If you're a developer or IT admin, you’re probably tasked with managing multiple websites, servers, applications, and levels of security on a daily basis. While this can be extremely time consuming, it can also be frustrating when systems aren't wor…
In response to a need for security and privacy, and to continue fostering an environment members can turn to for support, solutions, and education, Experts Exchange has created anonymous question capabilities. This new feature is available to our Pr…

593 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question