Drag&Drop to MyApp icon doesn't work

I thought I had this all figured out! I've written an app with its own icons on which the user can drop any icon. I've included the BNDL as well as FREF resources for ****, fold, and disk. Yes, the BNDL bit is also set.

When installing this file on a new machine, the icon does follow but the app doesn't recognize itself as being "droppable" (i.e. won't highlight). Rebuilding the desktop fixes the problem - but why should I have to???

What am I missing here?
LVL 2
mazurAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

boonstraCommented:
The Finder needs to have the information from your BNDL resource in the desktop database.  If you install using a copy, the Finder takes care of that.  How are you doing the install?
0
mazurAuthor Commented:
Exactly. I am just copying the file from my machine (where the BNDL is correct in the Finder's database and therefore works fine) onto a floppy, and then from the floppy onto the new machine.

In the old days, I would just go into the Finder's resources to see if the BNDL rsrc got copied correctly.

0
mazurAuthor Commented:
Here is a little more info. I just copied file to another machine. Still no "drop"; rebuilt desktop and it still would not work. Deleted all copies of file, trashed Desktop DF and DB, rebooted. Copied file once more. Still NG. Rebuilt desktop (cmd-option) and now it works!

Is there really a difference between cmd-option and trashing Desktop files?

Also tried adding an 'open' rsrc but it didn't help.
0
Get expert help—faster!

Need expert help—fast? Use the Help Bell for personalized assistance getting answers to your important questions.

mazurAuthor Commented:
C'mon. Someone out there has been through this before!
0
roovCommented:
Well, all I can say is that I have been there before, and didn't figure it out. But the good news is that I've found an application (actually, something a friend wrote) that correctly "slaps" the icons into the desktop DB.

If you want it, post your email and I'll get it to you.

Reuven
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
mazurAuthor Commented:
Reuven,

Well, I really was hoping for an explanation! But just knowing that I'm not alone and that it isn't my fault does help a little. Although I never had a problem with the icons, just the "droplet" types.

Please send the app to: jeffmazur@hotmail.com

Hopefully this fix is permanent (i.e. after fixing the file on the HD, I hope I don't have to run it again to the copy on the floppy or again on the new machine).

Thanks.
Jeff
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Programming

From novice to tech pro — start learning today.