Apache - returning a 403 Forbidden

I am receiving a 403 when i try to access the default page.  Obviously, it's a permissions issue, but it's not the file/directory permissions nor is there an .htaccess file present.  It is a fresh install of Apache 1.3.9 with DSO enabled and everything else is default (eg installed on /usr/local/apache and root dir is /usr/local/apache/htdocs).  The web server is pointing to the right place but the default is not working.  It does work however if i point it to another directory (eg /www) that has an index page.  any help?
kyriosAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

t2ppCommented:
Check /var/log/error_log for clues.
0
vioCommented:
Maybe you dont have index.htm* within /usr/local/apache/htdocs? maybe you have index.htm instead of index.html and directory listing is denied. check whois owner of /usr/local/apache/htdocs and compare with /www. also compare permisions. And finaly check spelling.
0
kyriosAuthor Commented:
nope, index.html is present and i tried changing the owner and group of that as /www but to no avail.  spelling is also correct.
0
Big Business Goals? Which KPIs Will Help You

The most successful MSPs rely on metrics – known as key performance indicators (KPIs) – for making informed decisions that help their businesses thrive, rather than just survive. This eBook provides an overview of the most important KPIs used by top MSPs.

ramvinodCommented:
permissions should be set so that index.html is world readable and the directory where the html files are kept, are world readable & executable.
0
kyriosAuthor Commented:
in the question i already stated that the file/directory permissions were correct.
0
ramvinodCommented:
duh!. i would I know what you mean by correct file/directory permission.
0
psimationCommented:
is httpd running?
0
ramvinodCommented:
how about these directives in the conf files for apache.
<Directory />
    Options FollowSymLinks Includes
    AllowOverride None
</Directory>

<Directory "/usr/local/apache/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all
</Directory>

explanation for each is given in httpd.conf ( i think) that comes with apache
0
kyriosAuthor Commented:
sorry, it didn't work.  those are actually the default settings that comes with apache so they've been tested.  i'm just going to give up and use /www instead.
0
SynstheCommented:
There's a high possibility your files may be owned by "root", or another process that the server doesn't think should be sent over the line.

Change to your server root, ie ``cd /usr/local/apache'', and than type ``ls -al'' to get a comprehensive listing of the files in that directory. Look beside the listing for htdocs, and see if it says something like:

drwxr-xr-x   2 root   root     1024 Oct 20 17:52 htdocs/

Look inside the directory itself too (cd htdocs, ls -al again, and look at the names beside each listing). If they're owned by root, or another daemon process, than they will return your 403 error. You'll need to change all files in that directory to be owned by a specific user on your system. So pick a user, say your own, and type the following from /usr/local/apache:

chown -R user.user htdocs/

Where "user" is your users name. Such as on my machine I would type:

chown -R FlipSide.FlipSide htdocs/

Make sure the htdocs directory is set to 0755 (chmod 0755 htdocs/) and than try and access it from the web again. Hopefully it should work this time.
0
kyriosAuthor Commented:
nope, the owner is 110 and the group is 200.  this is the default that it is set to after you install apache.  anyways, i withdraw the question as i have succumbed to the easy route and just used /www instead.
0
logan69Commented:
Try changing the owner of the files to wwwrun and the group to daemon.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.