• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 262
  • Last Modified:

Suse6.2 hangs during boot, after SCSI init

I had a 200MMX 128Ram AHA2940 with an IBM SCSI-HD and a Microstar MS-5164 Motherboard. On my SCSI-Disk is SuSE6.2 (kernel 2.2.10) installed. the system worked well.
Now I've got a new Motherboard with a AMD K6-2/400. the other Hardware is the same. Since I had changed the board and the CPU, during booting of Linux, after initializing of my SCSI host adapter he show me all devices which are connected to it and then he immediately changes to a black screen, with nothing. the monitor switchs into the  powersave mode. rebooting isn't possible. Even a reset (by pushing the button) isn't possible I have to turn off my system for some seconds!
When I disconnect all devices from SCSI Host adapter, linux boots well (until it needs the disk), initializing of the SCSI adapter works well.
I wanted to reinstall Linux with the SUSE-Install disk (floppy and CD-Rom) but the same error occurs. With an old SuSE Install disk(Suse 6.1 with 2.2.5) it works fine.

may anybody helps me?
0
zulliger
Asked:
zulliger
  • 2
  • 2
1 Solution
 
zulligerAuthor Commented:
sorry, I've forgot to tell you what the name of my new motherboard ist:
Gigabyte GA-5AA with an ALi Aladdin V AGPset chip
(I'm not using an AGP graphic card, I'm using a Diamond Viper330 PCI)
0
 
clayjCommented:
I'm no AGP expert; but, is it possible that Linux is detecting the AGP chipset and expecting an AGP video board and monitor?

Also, just as a data point - does anything different happen if you try to stay "single user" from the lilo prompt?
0
 
zzonkerCommented:
This sounds like either an interrupt problem, or an Active IDE driver on your SCSI system. Since you're getting video for part of the boot process and then it quits, I'm leaning toward the IDE is trying to detect, and crashing because the SCSI is using those interrupts.

Solution: (these are not for your specific BIOS, you may have to translate)

o Get to the BIOS Setup Screen (normally press the DEL key during the memory check, but the exact key to press should be displayed)

o Under STANDARD settings, make sure that the drives are DISABLED. They default to AUTO detect on most modern motherboards, and conflict with the SCSI card.

o Under CHIPSET or ADVANCED settings, disable "assign IRQ to Video." Your SCSI card may be using IRQ12 if it is designed to co-exist with IDE devices.

o Under PCI or PLUG-N-PLAY settings make sure the IRQ for the SCSI card is properly setup based on whether it is an PCI or ISA device. You Problably want to RESERVE IRQ 14 and IRQ 15 if you have an ISA SCSI card.

One of these suggestions should solve your problem.

If not, carefully check the device selection on your SCSI devices.. from what you've written they shouldn't have changed, but one or more may be software set and have been reset by being disconnected.

Hope this information is helpful.
0
 
zzonkerCommented:
one last thing you may check:

o Make sure that pin 1 of the SCSI cable connectors line up with the red (colored) end of the cable on all connections.
0
 
zulligerAuthor Commented:
I thank you for your answer. I tried everything you wrote me. but the system didn't work.
the problem is, that windows NT4.0 boots without any problems...
to solve the problem, I chaned my SCSI-card (ncr85xx). Now the system works very good.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 2
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now