NIS problems

Problem configuring Linux, RH6.0, with the new NIS Master server.  

Here's what's happening...

I have an Ultra1 up and running as the NIS master.  I have a sparc20 up as an NIS client.  Therefor I know that ypserv is running on the Ultra1.  That and I see it when I ps for it.  However, for some reason the Linux boxes are not binding to the NIS server.  I am attempting to use a Linux box as a slave server but I get the following output when I run the /usr/lib/yp/ypinit -s #servername#...

Can't enumerate maps from kcsns1. Please check that it is running.

Now, I have the domainname being set in /etc/rc.d/rc.local, and I have also created an /etc/defaultdomain file with the proper domainname in it.  

As far as I can tell everything is setup properly.  I was able to get the Linux boxes up, without any problems, before we moved to the new facility.  

Also, I am unable to setup any of the Linux boxes as clients either due to the same problem.

Does anyone have any ideas?  

Thanks :}

aaronhirschAsked:
Who is Participating?
 
sane101999Connect With a Mentor Commented:
This indicates that a command equivalent to "ypwhich -m" is failing to obtain the inventory of available maps from the NIS master during the execution of "ypinit -s".  I have had this problem before with a sufficiently crippled NIS master.  I presume that the Ultra 1 is running Solaris with NSKIT 1.2; make sure that you have all of the NSKIT patches from the SunSolve web site installed.  You should also make sure that your slave server is in the ypservers map and that its IP address reverse-resolves to a hostname correctly (try pinging its IP address from the NIS master).  Only if the master recognizes it as a slave server will it permit "ypwhich -m".

If you can't fix the master, one way to work around this problem is to fake the execution of "ypinit -s" by manually copying the DBM files from your NIS master's map directory (usually /var/yp/`domainname`) to the same location on the slave.  Another (which I prefer) is to copy /usr/lib/yp/ypinit and replace the line which runs "ypwhich -m" (or the equivalent "yphelper --maps $MASTER") with the line "maps=`cat /root/ypmaps`".  Create /root/ypmaps with a list of map names which the slave should obtain from the master, then run the modified ypinit -s.  This bypasses the attempt to ask the master for its map list, but still uses the approved ypxfr technique to copy the maps.

Hope this helps.

- Michael K. Edwards
  SANE.net, LLC
  (medwards@sane.net)
0
 
aaronhirschAuthor Commented:
Thanks for the advice Michael.  However, now that I have edited ypinit I get the following output when I attempt to run /usr/lib/yp/ypinit -s *NISMASTER*
Trying ypxfrd ... not running
No such map in server's domain
ypxfr: YP server/map db error

We will need a few minutes to copy the data from kcsns1.
Transferring cat...
Transferring /root/ypmaps...

scarecrow's NIS data base has been set up.
If there were warnings, please figure out what went wrong, and fix it.

At this point, make sure that /etc/passwd and /etc/group have been edited so that when the NIS is activated, the data bases you have just created will be used, instead of the /etc ASCII files.
0
 
sane101999Commented:
Looks like the NIS map transfer daemon (ypxfrd) is either not running or not correctly registered with rpcbind (aka portmap) on the NIS master.  Is it possible that the Ultra 1 doesn't know that it is the master server for this domain?  Look in the script in /etc/init.d (I think it's /etc/init.d/rpc) which starts ypbind.  It should check some setting, I forget what, to see if it is the NIS master and should start ypxfrd.  You should also check the securenets file (in /var/yp, I think) to make sure that the NIS master will permit map transfers to the address of the slave.

If ypxfrd is running but isn't serving what the Linux slave expects (actually, this is likely since the NYS ypxfrd documentation comments on conflicting file formats), you may have to set up a different map transfer mechanism.  If you post the details of your Ultra 1's setup (uname -a, showrev -p, etc.) and your linux slave (uname -a, /usr/lib/yp/ypxfr --version), I may have a chance to clone it and see what it takes to make it work.

- Michael K. Edwards
  SANE.net, LLC
  (medwards@sane.net)
0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 
aaronhirschAuthor Commented:
Thanks for the advice Michael.  However, now that I have edited ypinit I get the following output when I attempt to run /usr/lib/yp/ypinit -s *NISMASTER*
Trying ypxfrd ... not running
No such map in server's domain
ypxfr: YP server/map db error

We will need a few minutes to copy the data from kcsns1.
Transferring cat...
Transferring /root/ypmaps...

scarecrow's NIS data base has been set up.
If there were warnings, please figure out what went wrong, and fix it.

At this point, make sure that /etc/passwd and /etc/group have been edited so that when the NIS is activated, the data bases you have just created will be used, instead of the /etc ASCII files.
0
 
aaronhirschAuthor Commented:
Sorry for the delay in getting this to a resolved issue.  The Linux box is down due to a hardware problem and I am awaiting replacement parts.  As soon as they arrive I will continue to work the issue.
Thanks again!
0
 
ohad23Commented:
when i needed to configure the NIS server, all i did was to edit one file in /etc (ypserv.conf if i remember right) and configured the client using linuxconf. all the above was done on i386 computers and RH6.0 about 2 months ago. everything went smoothly except for the fact that the server forgot his domainname after boot, but that was fixed.
0
All Courses

From novice to tech pro — start learning today.