CD-ROM not accessible; compatibility mode/ASPI problem

Win 95: In searching for the best program for my CD-R, I installed both Nero and Easy CD Creator. I got a Vxd error, could not recover after uninstall and had to reinstall Windows (without format) in hope of fixing the CD drivers that were corrupted. Now, my system does not recognize either CD drive and goes into compatibility mode after detecting 16-bit components along with the regular ones in my Std Dual IDE PCI Controller. I suspect a previous trashed install of CeQuadrat PacketCD of leaving behind elements of it's filesystem and ASPI.  Is there any way now for Windows to recover the CD drivers short of a C: format?
PS: It's a tough one, but I had no more pts left to allocate, sorry.
OneirosAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

TedSennCommented:
Have you tried deleting the CR in device mamanger, booting and reinstalling the CD?
0
rayt333Commented:
If your computer contains a PCI-IDE hard disk controller that employs serialization between
  the two IDE channels, you may experience the following problems:

       32-bit file system access and 32-bit virtual memory are not available.

       Device Manager displays an exclamation point in a yellow circle for the primary and secondary IDE
       channels.

  Removing and reinstalling the hard disk controller does not resolve the problem.


  CAUSE

  The protected-mode driver for the hard disk controller was not properly initialized when you
  started Windows previously. When this occurs, a NOIDE entry is placed in the registry,
  preventing Windows from making future attempts to initialize the protected-mode driver.


  RESOLUTION

  NOTE: The purpose of the registry key mentioned in the RESOLUTION section of this article
  is to prevent data corruption. Before you change this key, Microsoft recommends you
  perform the troubleshooting steps listed in the following Microsoft Knowledge Base article:

       ARTICLE-ID: Q130179
       TITLE : Troubleshooting MS-DOS Compatibility Mode on Hard Disks.


  WARNING: Using Registry Editor incorrectly can cause serious problems that may require
  you to reinstall Windows 95. Microsoft cannot guarantee that problems resulting from the
  incorrect use of Registry Editor can be solved. Use Registry Editor at your own risk.

  NOTE: For information about how to edit the registry, view the Changing Keys And Values
  online Help topic in Registry Editor (Regedit.exe). Note that you should make a backup copy
  of the registry files (System.dat and User.dat) before you edit the registry.

  To cause Windows to attempt to reinitialize the protected-mode IDE driver, remove the
  NOIDE entry from the following registry key:


  HKEY_LOCAL_MACHINE\SYSTEM\CURRENTCONTROLSET\SERVICES\VXD\IOS

  If you are using Windows 98, navigate to the Tools\Mtsutil folder on the Windows 98
  CD-ROM, right-click the Noide.inf file, and then click Install. This should remove a NOIDE
  entry if it exists. After you use this file, restart your computer.

  After you update the registry, restart Windows. Windows will then attempt to initialize the
  protected-mode driver for the controller. If no problems are encountered, the file system
  and virtual memory will operate in 32-bit mode, and Device Manager will not display an
  exclamation point in a yellow circle for the IDE channels.

  If the protected-mode driver is not initialized properly, an error message will be displayed
  and the NOIDE registry entry will be re-created. Windows will use the MS-DOS compatibility
  mode file system the next time you start the computer.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
OneirosAuthor Commented:
Thank you! I can now access my hard drives in protected mode.
However, both my CDROM and CDR/RW units remain inacessible. I tried forcing recognition of my CDROM unit (Hitachi 8130) using MSCDEX and the DOS driver, but it still only accesses it in compatibility mode. As it is an older unit, I never had any Windows drivers for it to begin with (in the form of an .inf file or some such). As for the CDR/RW (Ricoh MP7040A),  I only have the firmware embedded in the accompanying Nero software to recognize it with. I will try removing the drives physically, rebooting and then reinstalling them in hopes of the system recognizing them automatically. Short of that, I can only reinstall Windows again; I don't know which particular Windows file contains the CD-ROM info, and whether or not it was damaged.
Thank you again.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.