Server error when publishing with FP!

Every time I try to publish to our server, I get an error message that says: "Server error, cannot create file d:\inetpub\wwwroot\sitename\default.htm" or some other file name. Other times it says "cannot delete ..." Our web server is running Windows NT and IIS4. What's up?
JCSAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joejansCommented:
Are you using FP2000?  If so, turn off "Execute" rights, and leave scripting on for the web in the management console.  In the new security template that MS is switching to, if an account has execute rights, you cannot upload content. I know there is a work arround, but I am not on my server, and would have to look and see what we did. In any case, if you have scripting turned on, everything should still work fine, as long as you aren't running any ASAPI "plug-ins" like Cold Frustration errr Fusion.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
JCSAuthor Commented:
Yes, I use FP2000.  Do I "turn off Execute rights and leave scripting on" somewhere in FrontPage or is that done on the server? I would like to know more about the "work around." I do not use any ASAPI plug-ins at this time.
0
joejansCommented:
This is done from the IIS Management Console on the server.

If I remember, we had to set some the security settings manually in NT.  Again, I am not at the server, and we only had to do this for a couple of the webs on one of our hosting servers with Cold Fusion.  

We usually just turn off execute permissions.  Unless you are doing something very advanced or different, you won't need execute permissions.
0
MoondancerCommented:
This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed.  Also a question is posted there specific to these changes that apply to the experts here.  Also, I am including the link to our All Topics, since many new ones have recently been added.

http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
http://www.experts-exchange.com/jsp/zonesAll.jsp
 
Thank you,
Moondancer
Moderator @ Experts Exchange
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.