error spwning cl.exe

i just unstalled ms dev studio v6.0
and hen i tried to compile a program it gave me 1 error - error spawning cl.exe.

please help me on this, i never experienced v6.0 errors.

suby.

p.s:the program-

#include <iostream.h>


void kishkashta(char *name="suby",int num=10);


void main()
{
        const int SIZE=30;
        int num;
        char *name=new char[SIZE];


        cout << "please insert your name.\n";
        cin.getline(name,SIZE);
        cout << "How many times would you like to see your name printed on screen?\n";
        cin >> num;


        cout << "the default operation:\n";
        kishkashta();
        cout <<"\nyour settings:\n";


        kishkashta(name,num);
}


void kishkashta(char *name,int num)
{
        int i;


        for (i=0;i<num;i++)
                cout << name << "\n";
}


10x in advance, suby.
suby101199Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

nietodCommented:
The error you are getting has nothing to do with your source code.  It sounds like visual studio cannot find the compiler--cl.exe.  Did you reboot your computer since you installed?

0
nietodCommented:
If that doesn't help, look for cl.exe  (you can use the file find option under the start menu).  The program should be in the ??????\VC98\BIN directory and it should not be anywhere else.  

If it appears in other directories, let me know.
If it doesn't appear in the vc98\bin directory, you may need to reinstall

Otherwise, make sure that the VC98\BIN directory is in the vissual studio search path.

Let me know what you find.
0
suby101199Author Commented:
i rejected the answer to unlock the question so other experts can contribute.

i dont have cl.exe in my drive where i installed the program.

ofcoz i rebooted after installation.

im looking for a different solution then "reinstall the program"....

suby
0
Cloud Class® Course: Ruby Fundamentals

This course will introduce you to Ruby, as well as teach you about classes, methods, variables, data structures, loops, enumerable methods, and finishing touches.

nietodCommented:
cl.exe is the compiler  What sort of alternative might there be?!!!!!

If you don't have it, you MUST install it--or not compile....

Did you have problems when you tried to install?
0
jkrCommented:
See http://support.microsoft.com/support/kb/articles/Q188/7/20.ASP

This article describes your problem in detail and also offers a solution for it.
0
nietodCommented:
jkr, I already suggested that.  I said

>> make sure that the VC98\BIN directory is in the
>> vissual studio search path.

But according to suby, the cl.exe file is not even installeed.
0
jkrCommented:
Hmm, the article I mentioned also mentiones some other 'less obvious' alternatives. I also think that's a misunderstanding, as I hardly can imagine that cl.exe is missing...

(BTW: suby, if the search path issue applies, please reject and invite nietod to answer...)
0
nietodCommented:
Huh, I didn't see any other posibilities mentioned.  I didn't pay enough attention, probably because in the past the problem always has been the path.
0
suby101199Author Commented:
goddamn i reinstall the whole thing.
now the program compiles BUT A NEW PROBLEM OCCURS.

first the program runs very fast.
milisecond and its executed and dissapeared.

i get this:
Loaded 'C:\WINDOWS\SYSTEM\KERNEL32.DLL', no matching symbolic information found.
The thread 0xFFC5DCD5 has exited with code 20 (0x14).
The program 'C:\Program Files\Microsoft Visual Studio\MyProjects\homework1\Debug\homework1.exe' has exited with code 20 (0x14).

please help me resolve this.

suby
0
suby101199Author Commented:
Adjusted points to 60
0
jhanceCommented:
How much RAM do you have in your system?

The only time I've seen problems like this is when I've run out of system resources.  If you are very short of RAM, you might get this right off the bat.
0
nietodCommented:
I don't see evidence of a real problem now.

The program is running to completion and ending.  Nothing you've reported is an error message.  Those are typical messages.  You do not return a value from main--and you should, so the return value is random.

"homework1.exe' has exited with code 20"

Why do you think there is a problem?

Like did you expect to see the messages you pritned to cout, but don't see them.  if that is the case you are probalby creating the wrong type of project.  This should be a win32 console application project.
0
jkrCommented:
>>Loaded 'C:\WINDOWS\SYSTEM\KERNEL32.DLL', no
>>matching symbolic information found.

This simply means that you have no kernel32.dbg file on your machine.
0
suby101199Author Commented:
i usually got a "press enter to continue" in version 5.
now the program flies by - after performing what it should [i get the text as needed] and exited and i get that msg.

1-am i to understand there is no problem?!
2-no kernel32.dbg file...huh?! good,bad,needs fixing-what?
3-how do i get back the "press enter to continue"?!


0
suby101199Author Commented:
Adjusted points to 70
0
nietodCommented:
>> usually got a "press enter to continue" in version 5.
What do you mean?  Where does this message come from?  Your program doesn't have any prompt like this.  Vc doesn't have a prompt like this.

>> now the program flies by
What do you mean by that?  does it not wait for you to enter input?

>> after performing what it should [i get the text
>> as needed]
That sounds like the program is running okay.  is it?

>> i get that msg.
none of the messages you got are really indications for problems.

>> 1-am i to understand there is no problem?!
We don't see any evidence of a problem.  If you do, describe what you think is evidence of a problem (describe the behavior that you are seeing.)

>> 2-no kernel32.dbg file...huh?! good,bad,needs fixing-what?
Not a problem.  it says it can't find the debug symbols for the OS's kernal DLL.  No problem,b ut you might have a little easier time debugging if it could find those symbols.  I believe that under the vissual studio program menu (int he start menu) there will be a menu like "Microsoft Visual Studio Tools"  Inside there may be a menuy option for "Symbols Setup"  Try running that

>> 3-how do i get back the "press enter to continue"?!
where did that come from in the first place?  
0
nietodCommented:
>> 3-how do i get back the "press enter to continue"?!

I know what you mean.  That prompt prints after your program finishes.  When you respond it closes the console window.  right?  

That prompt has nothing to do with your program or with visual C++.  The OS prints that prompt when a console program has finished and the console is to be closed.  Under windows 9x you can turn this on or off by right clicking on a DOS console icon and obtaining its properties.  Then under the "porogram" tab make sure that "close on exit" is not checked.  If it is not checked, the OS will prompt before closing the window.  If you have NT, I have no idea what to do to control it there.
0
suby101199Author Commented:
its indeed the message i should get when the program finishes.

again-program runs fine, but it runs quickly and shutsdown the screen automatically without giving me the "press enter...." message before closing.

the properies of the console window did not help.

i need to restore that messy...worked on v5 of the studio and i dont know how 2 bring it back!!!

suby
0
suby101199Author Commented:
Adjusted points to 80
0
nietodCommented:
What OS is this for?
******************************
As a temporary fix, you can just add

char ch;

cout << "press enter to continue."
con >> ch;

at the end of your program.
0
AdihCommented:
i think i got it:
u r running debug (F5) and debug does not give u the prompt "press enter to continue".
just press CTRL-F5 for running the program and it will give u the prompt as required!

let me know if it helped!

adi
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nietodCommented:
Control-F5 will run the program without the debugger, though.   And I'm not sure that will actually make a difference.
0
suby101199Author Commented:
woh,it worked...
i pressed ctrl-f5 and it asked if i wanna rebuilt and after saying yes it compiled and linked and ran and i got the "press enter..." pronpt!!!!

the exe does`nt give me the prompt though but runs by likein debug...

but im content.

post an answer adih and ill grade it.

10x alot nietod, ill post another question for u with the points i got left to express my gratitude.

suby
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
C++

From novice to tech pro — start learning today.