Modem assigns it's own com port

I have an issue where the hard drive had to be formatted and Win98 re-installed. Ever since this took place the modem (internal, USR 56k), rather than using com1 or com2, its assigns itself to com3 or com4. However, this only happens when the modem shows up as a new device at start-up, otherwise Win98 does not find the modem. If I let it stay on com3 for instance, since com3 does not exist, I get the message: "Unable to open port" when I try to get 'More Info' on the modem.

I have tried deleting the com ports themselves and re-installing them, and there are no conflicts to be seen.

Anyone have any ideas?
nm_mainAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

jatcanCommented:
What's the model number of the modem & did you use the driver disk to install the drivers or did you try using the win98 supplied  drivers?

What other devices do you have on your system? Is there some type of problem concerning using com 3(other than the obvious)IE.-another device is already using com 3.?

Jatcan
0
dew_associatesCommented:
NM, this is quite common. There's a couple of ways to handle this depending on whether your modem supports (and is configured for) plug and play.

Method 1:
===============
Boot the system into Safemode, go into control panel, device manager and click the + sign to expand. Now remove all modems listed. Now close windows normally.

Restart your computer into the Bios\Cmos setup. Disable both com (serial) ports for now. Save the settings.

Now boot into Windows and it should find the modem and install it on either com1 or 2.

Once this occurs, boot back to the Bios/Cmos setup and re-nable one of the com ports, save the settings and boot normally.

Dennis
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
nm_mainAuthor Commented:
dew associates(Dennis),

Thanks for the idea.

I will try it and accept the answer for you if it works.....

nm_main
0
dew_associatesCommented:
Okay, but if there are problems, let me know and we can try the other methods. What I posted is the most common, but if the modem has jumpers that predetermine the com port, than we'll need to try an alternate method. Sometimes though, Windows inadvertanly loads duplicate devices that can only be seen while in safemode.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.