RedHat 6.1 pppd died unexpectedly

In Mandrake 6.0 I was able to set up kppp without any problems.  I then tried Redhat6.1 and tried to set kppp up but it always says the pppd deamon died unexpectedly.  I watch the log and it dials ok.  I then see the username prompt then the password prompt then a bunch of data characters and immediately the pppd dies.  I put the debug option in pppd options and checked the output of /var/log/messages  and it said "pppd :  The remote system is required to authenticate itself but I couldn't find any secret (password) which would let it use an IP address."  Using minicom I can dial the modem and connect.  I get the prompt for the username then the password and after that all the data starts coming in.  So that tells me it is not PAP or CHAP authentication.  I choose script based login from the kppp options (I also tried the others with the same results).  I filled in DNS settings.  I tried putting "noauth" as a pppd option and after the password prompt it stays up for 30 seconds (kppp says "Logging on to Network") and then dies.  30 seconds is the timeout value for pppd.

I also tried Redhats new RP3 to setup the connection but I get the same result.

It must be a configuration problem but where?
The options file for pppd just has "lock" in it.
I've tried all this logged in as root and as another user.

ejohnson0547Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

serena77Commented:
Be sure that /etc/ppp/options contains the follow:

asyncmap 0
auth  
crtsct
lock  
modem
noipdefault
ipcp-accept-local
ipcp-accept-remote
debug

the options auth and lock are needed, please do not disable it.

Serena
0
crouchetCommented:
Not so, friend. MY ISP gives me a logon pompt if I connect with minicom, but also happly does PAP logons if I dial with kppp.

The moral is, logon prompts do not mean no PAP/CHAP. Call your ISP and ask. Yeah, I know, that means actually talking to another human being. Very scary.

Ok, so if you have PAP (a good bet unless your ISP is maned by a bunch of clowns) you need to configure kppp to use PAP. But wait! There are a few tricks.

First, cruise out the the web site for your modem and find the setup string for your modem when it is doing PAP. My US Robotics modem requires a special initialization string to use PAP and I'd bet yours does too. (Anyone keeping track of these bets?) Actually I got my string from my ISP so you might try there too.

In kppp put that new initialization string in under the modem tab.

Next, in kppp DO NOT use the device /dev/modem. Use /dev/ttyS1 (or S2 if you are on port2).

Next (still in kppp) edit your account. Under the Logon Script tab, first get rid of all the stuff you have put in there. Next add a Pause 2. If you have done it right that Pause will be the only command in the Logon Script.

Unelss you are a bind guru and have done some fancy setup you will aslo need to hit the DNS tab and click the "Disable Existing DNS" box so your computer's lame attempt at DNS does not interfere with the real thing. Next click over to Gateway and make sure "Default Gateway" is chosen.

Make sure you fill in all the DNS addresses, phone numbers and all the other fru-fru kppp asks for. Once you are finished with the account portion, click on the PPP tab and change the timeout to 60. Unless your ISP always picks up on the first ring you will not finish the logon in 30 seconds.

Now, if you have put anything into pppd go back there and erase it all. Well, ok, write it all down first in case I turn out to be a doofus. But really, if you are going to use kppp you need to count on kppp to pass this info.

If this feels like a pain in the rump, you are proably on the right track.

Try it. If it works, buy it.

J Crouchet
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
sclCommented:
!!!!ejohnson0547 !!!
Please comment here if you managed to make kppp work, and if so, then how ?
Please, this will help ALOT.
Thanks.
0
crouchetCommented:
Well, *I* have gotten it to work on a number of systems using the instructions from my answer above. If you tried that and it did not work for you, post a question to the forum and someone (maybe me) will try to help you.

I would guess that since Mr. Johnson accepted my answer, it must have worked for him too.

J Crouchet
0
ejohnson0547Author Commented:
Sorry its been so long I had forgotten about this post.  I am not using Redhat any more but I do remember finally getting it to work.  It was some problem between the default route on my network card and the modem.  I used rpm to uninstall the networking packages and reinstalling and it seemed to work then.  Sorry I don't remember any more details...
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Networking

From novice to tech pro — start learning today.