Not recognizing Network Interface Card

While installing Linux Redhat 6.0 version on my new Compaq Presario 96MB RAM ,500MHz,13.8Gb HDD machine with Diamond Home PNA+ Ethernet Based Adapter using CD-ROM install method,the Network device driver list does not include the Network driver available with my Compaq PC. The following error recurs when I try installing with any of the drivers in the list:
Error: The hardware device is not detected.
Question: How can I succeed in installing Redhat Linux 6.0
          making use of the Network card avilable with  
          my new computer?The Install also does not    
recognize my Display Adapter(S3 Inc.,Savage 4 GT 8Mb BitFlip Engineering).How do I solve this problem?
Details:
Product: Redhat Linux 6.0
Error Message: Hardware devices for Network card and Video card not detected by the CD-ROM install of Redhat Linux 6.0
Computer Details: Compaq Presario,96MB RAM,500MHz, To be Configured as a LAN and Web Server.
Operating System:To load both Windows 98 and Redhat Linux 6.0
Network Card(Adapter):Diamond Home PNA + Ethernet Based Adapter
Video Card: S3 Inc., Savage 4 GT 8MB BitFlip Engineering
Contact Information: Name -Mk Reddy
                     email-mkreddy4@hotmail.com
                     fax:510-739-0192

 
mkreddy110399Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

AstromanCommented:
This isn't an answer because I have no way of checking properly what you need to do, but I had the same problem.

Linux probes for a network adapter at a certain address (eg x220). What you need to do is override this in the /etc/modules.conf file.

Have a search through some howtos and FAQ's (e.g. cd /usr/doc/HOWTO ; grep eth0 *)

and see what you come up with. You should be able to find the correct settings in windows.

You should install as best as you can and then fix the problems. The install scripts aren't perfect.

Hope this gives you something to work with (p.s. this Q should be in the Linux setup area really)
0
nicademusCommented:
Answer:
         Firstly let it install everything else, so that you have a running, albeit Network and X11less box, making sure you have access to a working win95/win98/NT installationg, also on that system.

      Next.  If your kernel supports the VFAT file system, this means you can mount the WIndows 95/98 partition from Linux, and having previously downloaded (using Windows) XFree86 3.3.5.  You need to transfer this to Linux, decompress the three files, un-tar them, and compile & install them.  This will take a while to do.  But this will give you support for the Savage 4, after you use the standard XF86Setup program.

Next.
       Whilst Windows was happily downloading the three XFree86 files you were also surfing for a driver for the LAN card  I have never heard of the card, but maybe on a driver disk that came with it, or at the manufacturer or distributors WEB site, you will find a lovely little Linux Network driver file. (there may be a few files, if they have a precompiled file it will be somwething maybe like:     dhomepna.o
this is a module file which needs to be loaded as part of the boot process.
if you edit the /etc/rc.d/rc.sysinit file and add something like this.
-----where it says # Set the path, and #Read in COnfig data, these are already in the file, but I have shown where I have my modules loaded for the ne2000 compatible (two of them)  If you only have one just put in the line (with proper file name) which I have written below all this....


# Set the path
PATH=/bin:/sbin:/usr/bin:/usr/sbin
export PATH
#Loading of network drivers
modprobe -v ne io=0x300,0x340
# Read in config data.      


These Lines------>
echo "loading Network Drivers"
modprobe -v filename
echo "Completed network card loading."

The Echo's are just so you can get a visual, in case the module tends to hang the system, you will know it if is IT or something else.

Next, once you have logged in as root, you run netconf
and set up the network card to be eth0

and where it says Kernel Module, just put in the name of the module, without the .o

Any probs with this description, just let me know.


Leigh Green
greenlight.computing@surreyhillsps.vic.edu.au
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.