turn off pcmcia modem speaker

Hey all,

I run SuSE linux 6.1 and my pcmcia modem is running very sexily indeed... apart from it has the speaker enabled and I'd like to turn it off... those connection noises get to me after a while.

How do I do this ?
LVL 2
gravityAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ILLUSIONCommented:
Go into your kppp and slide the modem speaker voolume bar all the way to the left.
0
gravityAuthor Commented:
I'm sorrym but I don't use kppp because I use connection scripts.

Also, that's not what I asked for... I actually want to turn off the option that enables the card to use the speakers.
0
zzonkerCommented:
if your modem is V.34 or V.90 compliant you need to add
the following to your initialization string:

AT M0L0                  (note those are zeros)

if there is already an initialization string there you don't need the AT, just add the M0L0  to the end of the initialize string you have.

I could tell you exactly what file to edit if you'd be more specific about what program you are using to connect to the internet and what model/brand of modem you are using.

0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

ILLUSIONCommented:
Yep that was what I was thinking but wasent sure so I didnt wanna say anything in case it caused problems
0
gravityAuthor Commented:
I'm using the standard pcmcia drivers that come with SuSE run thru the simple "cardctl" and "cardmgr" commands.

I'm not interested in altering the connection files - I'd rather turn off the speaker option altogether.
0
guiyuCommented:
Add:
                   
module "serial_cs" opts "do_sound=0"
                           
to*

/etc/pcmcia/config.opts

(from "man serial_cs") will disable speaker output completely, (cardctl should show speaker OFF)

* or wherever your pcmcia modules configuration files are stored under SUSE
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
gravityAuthor Commented:
Thanks  a lot for that... you've made me happy ;)
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.