Linux-Mandrake modem installation/configuration

I'm just a Linux beginner, so go easy on me.  I've just installed Linux-Mandrake 6.0 on a homebuilt iPentium 120 with a FIC 2002 motherboard and an internal Supra 336i voice fax/modem.  The bootup shows that the PnP recognizes 02f8 as the port address and IRQ 3, both ok.  I can't seem to get the software to recognize the modem.  Would someone give me a simple step-by-step for installing and configuring this modem for dialup access without all the extra explanations that just seem to complicate and confuse?  I'll figure out the whys and wherefores later.  
Thanks a heap!
GlitchAsked:
Who is Participating?
 
freelonConnect With a Mentor Commented:
What's the com port your modem is using?

These commands should be run as the root user.

If COM1:
ln -s /dev/ttyS0 /dev/modem
(that is a zero in "ttyS0")

If COM2:
ln -s /dev/ttyS1 /dev/modem

If COM3:
ln -s /dev/ttyS2 /dev/modem

If COM4:
ln -s /dev/ttyS3 /dev/modem

If you get an error that /dev/modem already exists, run "rm /dev/modem" first. Is this the info you need?

Have you checked the "Winmodems are not modems" web site, http://www.o2.net/~gromitkc/winmodem.html, to be sure your modem will work in Linux?

~f
0
 
GlitchAuthor Commented:
Edited text of question.
0
 
foxrCommented:
Disable PnP in your bios.  linux is not PnP savvy.  This should take care of your problem.  Also make sure that the internal serial port com1 or two that corresonds to your modem setup is disabled in your bios.  In the automatic setup arena, microsoft has a real edge over linux.  Overall though, I think you'll be quite impressed with linux.
0
 
GlitchAuthor Commented:
My bios doesn't have an option for disabling PnP.  It's an award bios on an older FIC PA2002 motherboard that's been flashed to the latest rev, but doesn't allow the option of disabling PnP.
0
All Courses

From novice to tech pro — start learning today.