no permission to access cgi-bin

I did a chmod 775 to this directory and still i get this message:

"You don't have permission to access /cgi-bin/ on this server."

Did i forget something?
rick_mulderAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

packratt_jkCommented:
the directory /httpd/cgi-bin  ??
0
rick_mulderAuthor Commented:
the site is called quod.

I created a directory:
quod/www
quod/cgi-bin


or does it need to be a httpd dir?
0
AstromanCommented:
You are trying to access it through the http daemon. You need to set the permissions up in the web server config files to allow _remote_ access, and if you want to run cgi scripts, you need to set up the server so it knows that it is allowed to execute the scripts in this dir
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

rick_mulderAuthor Commented:
ok, can you give some more info about this. You mean the httpd.conf file?


0
AstromanCommented:
Are you using Apache?

If you look in the httpd.conf file it should be fairly delf-documenting when it comes to cgi stuff.

I don't have a file here in front of me, so I can't tell you the exact thing to put in it right now.

Just open it up in a text editor, and search for 'cgi'. The default conf file is heavily commented, so should it shouldn't be too hard to figure out what to do.

Sorry I can't be more help.

Leon
0
GorGor1Commented:
if you are using Apache, look at your access.conf file.  On mine it's in /etc/httpd/conf/access.conf, but I'm not sure which Linux you are running.  There should be a few lines that look like:

<Directory /quod/cgi-bin>
AllowOverride None
Options ExecCGI
</Directory>

(/quod/cgi-bin should be replaced by the FULL path to your cgi-bin directory)

Since you created your own cgi-bin directory, you will more than likely need to add those lines to the file.  

That will do it if you're using Apache  :o)
0
packratt_jkCommented:
Is it on your computer or on some server somewhere?
0
rick_mulderAuthor Commented:
on a server.
0
packratt_jkCommented:
Try sending an email to the sys admin and ask him.  If it's not your computer then you really have no way of knowing how it is set up.

 It would also help if you gave us the web address so that we can go look at it.
0
rick_mulderAuthor Commented:
No, i'm figuring out how to set this server. So i'm the administrator you could say.

GorGor1, i tried it and it doensn't work!!
0
packratt_jkCommented:
Apache's default cgi-bin is:
/home/httpd/cgi-bin

The  default html directory is:
/home/httpd/html


your html code will refer to the cgi-bin directory as /cgi-bin

hope this helps
0
rick_mulderAuthor Commented:
does a cgi directory need to be called cgi-bin or can i also use another name?
0
GorGor1Commented:
I don't know if this will help, but whenever you make a change in your config files, you must restart your http server. Use this command:

/etc/rc.d/init.d/httpd restart

That's the command in Red Hat Linux 6.0...I'm not sure if yours will be different.  If all else fails, just reboot Linux.
0
GorGor1Commented:
I don't think you need to call it cgi-bin.  But you do have to make sure there is the option "Options ExecCGI" in the access.conf file for that directory.
0
rick_mulderAuthor Commented:
yes i know how the reboot the http-server :) thanks about that.

I'll give it another try..
0
packratt_jkCommented:
Unless you really want to start messing with the apache config file I suggest you go with the deaults
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.