Mount floppy disk drive.

I am the beginner of Linux.
I installed mandrake's linux 6.0 in my computer. When I go into the kde-windows manager and double click the "Floppy" icon on the desktop, the following message appeared:

----
Could not mount
Error log
mount wrong fs type, bad option, bad superblock on /dev/fd0, or too many mounted file systems
----

Actually, I can use the utility inside the kde to format a floppy to a linux supported format.

What does this message mean and what is the most possible cause for appearing this message ??

Thanx !!
Raymond
rngAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

packratt_jkCommented:
have you tried using a different disk
0
foxrCommented:
Make sure that the autofs daemon is running at boot.  also check permission on the mount and make sure the user has permissions to rwe on the mounted volume.  Also try different disks....can it mount formatted with FAT?  I believe the mount that comes standard with KDE on the desktop for floppies defaults to FAT.  Hope this helps.
0
ILLUSIONCommented:
Before you can mount a floppy disk drive you must insert a disk.
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

packratt_jkCommented:
can you mount in a terminal???
0
sirwinstonCommented:
From the error message, it looks like the computer tried to mount a bad or wrong kind of floppy, some mount settings were off, or the floppy was already mounted.  

(KDE icons don't need to be "double-clicked," but I doubt that was what you actually did. :)  

Anyways, you need to check a few files.  Log in as root and check the /etc/fstab file.  It should look something like this:

/dev/hda6  /            ext2    defaults        1 1
/dev/hda1  /c:          vfat    defaults        0 0
/dev/hda5  swap         swap    defaults        0 0
/dev/fd0   /mnt/floppy  auto sync,user,noauto,nosuid,nodev,unhide 0 0
/dev/cdrom /mnt/cdrom   auto     user,noauto,nosuid,exec,nodev,ro 0 0
/dev/zip   /mnt/zip     auto      sync,user,noauto,nosuid,nodev,unhide 0 0
none       /proc        proc    defaults        0 0
none       /dev/pts     devpts  mode=0622       0 0

Notice the fields for the line that starts with "/dev/fd0."  (FYI- fd0 corresponds to your first floppy drive and fd1 your second)  The first field is the name of the device.  The second field is the mount point of the device.  The third fieled is the kind of file system the device is.  Check to see if the third field is "auto."  This tell the computer to automatically mount the floppy in vfat (dos) or ext2 (linux) modes when you mount a floppy.

I haven't totally figured out what the last two fields are, but I just know that they have to be there.  So, make sure the line starting with "/dev/fd0" looks like the example above.  Don't just copy the whole example I've given, only the /dev/fd0 line.  I have a different system than yours.  

I'm assuming that fd0 exists in your /dev directory.

Next, check to see if there is an actual mount point "/mnt/floppy"  You can do this by checking the /mnt directory.  If it's not there do: mkdir floppy.  This will create a folder where your floppy will be mounted.  

Now, still as root, check the properties of the floppy icon by second clicking it.  Click on the device tab and make sure the device field is "/dev/fd0", the mount point field is "/mnt/floppy" and the file systems field is "default."  Do this for your normal account too (you can look in the /home/"loginname"/Desktop directory).  When adjusting your normal account floppy icon properties, make sure the permissions are set accordingly too ("owner" and "group" fields should be the login name).

Now insert a known good formatted floppy, click the icon and see what happens.  Make sure you second click the icon to unmount the floppy when you remove the floppy.  If all goes well, great, if not, check the files again for typos (or maybe the problem is deeper).

That's all I know for now.  I hope this "shotgun" method of troubleshooting takes care of those gremlins and I hope you get an idea of how Linux mounts files systems and drives. Check out the man pages for fstab.  For terminal mounting, check the man pages for umount and mount.  There are other ways of doing this but I think I've said enough.  Happy hacking.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rngAuthor Commented:
Dear sirwinston:

Do I need to unmount the floppy each time when I remove the disk from the drive ??

And do I need to mount the floppy again when I insert a disk to the drive ??

What does "second click" mean ??

Thanx very much !!

Raymond
0
sirwinstonCommented:
You don't "need" to do anything, but it would be wise to unmount a disk that does not exist.  Bad things might happen when you try to acces the disk that's not mounted.   Ever try to access the contents of a floppy when you have removed the floppy from the drive on a Windows machine?  It's the same deal here.  Windows and Linux don't automatically mount a floppy when you insert it.  You have to run a command to moun the sucker.  In our case- click on the icon which in turn runs a few commands.  On a Mac, it's different.  The mount command is invoked right after you stick the floppy into the drive.

Now if you have removed a floppy from the drive that's been mounted already, and stick the same floppy back in, and try to access the contents, (in that order of course) things will be OK.  As long as you don't try to acces the contents of the floppy when you've removed it.

I say second-click almost synonmously as right-click.  UNIX and Linux systems have mice with three buttons rather than two on Windows, (number three being in the middle button).   When I said second click the floppy icon, I meant right-click it to give you a menu.  One of the options on the menu is to unmount.  Have fun.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.