Excel CSV Country differences : URGENT

When I open a .csv file in an English Excel 97, all fields are put in columns.
However when I open it in a Dutch Excel 97, all fields are put in the 1st column.

HEEEEEELPP !!!

Country settings on both PC's are
Decimal symbol : "."
1000 seperator : ","
Field seperator: ";"

Csv file:
"xxx";"xxxxxx";"xxx";"xxxxxxxxxxx"
"xxx";"xxxxxx";"xxx";"xxxxxxxxxxx"
"xxx";"xxxxxx";"xxx";"xxxxxxxxxxx"
jlaureysAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

criCommented:
It should work, as the csv is not a comma delimited but a list separator delimited file:

a) Before continuing make sure the Dutch PC really has ";" and not ":", you might have made a typo your eyes do not see due to resolution and/or you already knowing what you will see.

b) Then try this fast and safe bet:
StartButton Run: excel /regserver  (there is a blank before the switch)
This will rewrite all the Excel registry keys.

c) Then, if not already done it, consult:
http://search.microsoft.com/Benelux/nl/
Use All words etc.

d) If nothing works _and_ you have to do it occasionally only: Rename the *.csv to *.txt, then the 'Text Conversion Wizard' (should) kick in. Then you are home free.
0
dtavassoliCommented:
This isn't a fix in itself, but your question seems urgent and this works. I have French Excel and I get the same problem, but here's the workaround :

CSV and double-click = all in one column
open Excel first and open CSV file = in correct columns

Hope it helps !

Dom
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
jlaureysAuthor Commented:
Thanks ... that gives me a work-around !
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Microsoft Office

From novice to tech pro — start learning today.