Screwed-up boot. Please help!

Hi. I installed Linux OK, but then added a line in etc/filesystems in order to use the Win partition, but I screwed it up and it doesn't boot Linux anymore. The rescue disk doesn't work either and I think all I need is a program to have access to that file in the Linux partition, but from Win o Dos (which work fine), so as to remove the line. Any ideas? Thanks in advance.
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

guiyuConnect With a Mentor Commented:
Sorry, I forgot to mention that you need to unmount the partition after editing it.

If your hda5 is a huge partition (4GB or larger), then what you observed was actually the computer's attempt to fsck(syncing) the disk (check your hard drive light, or listen closely for hard drive noises), which usu takes 3-5 mins for a 4 GB disk.

You can reboot again and wait till it finishes the checking, and then all should be ok. Of if that does not work, try booting from the RedHat CD again, and then manually run fsck on /dev/hda5

fsck /dev/hda5

(don't mount it).

(you can do fsck on all the partitions just to play safe).

And before you reboot, execute
to sync all partitions.
You should be fine once you remove the change you made in the /etc/filesystems file. The file you want to edit to mount windows is the /etc/fstab file. Don't know of any programs to read a linux partition from windows so I don't really have any useful suggestions to help you fix that.
There used to be a NT r/w program for reading ext2 partitions under windows, but it isn't there anymore.

Anyway, here is a program for reading the linux partition from windows:

Another way is to boot using the Red Hat installer disk, and go thru' the installation until the disk partition stage, then hit
CTRL=ALT-{F2 or F3 or F4}

to get into the console, from where you can try mounting your root file system, e.g.

mount /dev/hda /mnt

after it is mounted, you can edit the said /etc/filesystem, e.g. (depending on where your editor) with the command

/mnt/usr/bin/vi /mnt/etc/filesystems
The new generation of project management tools

With’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

I ran into a similar problem.  I noticed you said that the rescue disk (sigular) doesn't work.  To gain access to the files on your linux system, you have to have the boot disk and the rescue disk- two of them.  I don't remember how to create the second disk.  You can find out by booting from your single rescue disk and use the help options.  After you have the two disks, boot from the boot disk and type rescue at the prompt.  It will start booting and somewhere in the middle, it will ask you for the second disk.  Insert it and it should drop you into a shell prompt.  To mount partition you want to modify, you have to remember the device hda1 or hda5 or whatever.  Then type:

mount -w - t /dev/<yourdevice> <mountpoint>

mountpoint is the point where you want it to appear.  

Next cd into the mountpoint you made, make the changes and reboot.  Happy hacking.
Or, you could try to make a boot disk and a root disk (you need both), using RAWRITE that comes with RedHat and Slackware dists.


Some RAWRITE details, assuming an MS-DOS session from Windows and RedHat CD-ROM in drive D:

1. "d:\dosutils\rawrite.exe" at MS-DOS command prompt
2. "d:\images\boot.img" in response to prompt for disk image source file name
3. "a" in response to prompt for target diskette drive
4. Repeat 1-3, substituting "d:\images\supp.img" at step 2

best of luck to you
f_suarezAuthor Commented:
Thanks guiyu, Explore2Fs works fine but it only reads files (it doesn't save them). However, I used the red-hat cd to boot, mounted hda5, edited the file and unmounted /mnt before rebooting. To my surprise it still fails. When booting it reads "hda5 not unmounted correctly - check forced" and then hangs when starting SYSLOGD. Any ideas?

Can it be that after unmounting I couldn't go "reboot" nor "shutdown" 'cause they don't work?
f_suarezAuthor Commented:
Thanks man!
All Courses

From novice to tech pro — start learning today.