Posted on 1999-11-10
Medium Priority
Last Modified: 2010-04-22
I have downloaded the latest 2.2 kernel source installed it on my openlinux1.3 system and configured and compiled the kernel. When i then boot the computer it will boot up to a point and the a modprobe error happens and this then is continual echoed to the screen so i can not tell what the problem is.
Question by:Marktalbot

Expert Comment

ID: 2196979
Did you also do

make modules


make modules_install

, to speak the obvious.

Expert Comment

ID: 2197452
The problem is you've upgraded the kernel but not the modules.
You'll need to get the 2.2 modules for Openlinux.

Author Comment

ID: 2198122
I have made the modules from the source code and so this has alredy updated the system. I have the auto kernel loader option on.
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.


Expert Comment

ID: 2198446
I had this happen once too.  Strangely enough, I can't exactly remember what I did to fix it.  I looked through the man pages of modprobe, and there is an option that you can send to modprobe to stop it looking for certain modules.  I think it is "modprobe -r <module to remove>".  If you want to see what modules it is looking for, try a "modprobe -a".  Also check out the depmod command.

By the way, I hope you are able to boot into Linux from a floppy, otherwise, this probably won't help much.

Good luck,


Author Comment

ID: 2199996
i kept the old 2.0.13 kernel active so i boot off that. I dont actualy now what modprobe is upto because the screen is scrolling to fast. I removed autokernel module loading support and it still did this

Author Comment

ID: 2199997
i kept the old 2.0.13 kernel active so i boot off that. I dont actualy now what modprobe is upto because the screen is scrolling to fast. I removed autokernel module loading support and it still did this

Expert Comment

ID: 2220285
Probably it's yout eth0 device ,
does it sais

Modprobe: Can't locate module lo:1
Modprobe: Can't locate module lo:2
Modprobe: Can't locate module lo:3
Modprobe: Can't locate module eth0:1
Modprobe: Can't locate module eth0:2
Modprobe: Can't locate module eth0:3
Modprobe: Can't locate module eth0:49

Try /etc/rc.d/network restart and check
if you get the same error then the one
when booting.

Normally it should be no problem, except
that this message only should appear in
/var/log/messages and not the active tty

You can check /etc/conf.modules for
errors, and you can check /lib/modules/2.2.x
if these modules you used are present.

Author Comment

ID: 2222089
I don`t have a ethernet device

Accepted Solution

crouchet earned 50 total points
ID: 2229805
You need to check the logs. use the dmesg command. For more complete information you may want to view the message log directly with this command:

less /var/log/messages

You will be interested in the end of this file. A quick way to view only the end is this command:

tail /var/log/messages

You can only do these things if you are logged in as root.

Bonus answer ----> I had a similar situation. My problem was that the parallel port module had a different name than what was being called for by the kernel. I found this because my printer would not work. If your parallel port is working, you have a different problem.

Anyway, the fix was to add these lines to /etc/conf.modules

alias parport_lowlevel parport_pc
options parport_pc io=0x378 irq=7

substituting your io port address and irq, if they are different from these.

J Crouchet

Expert Comment

ID: 2229968
1 ultra remote possibility:

Did you

1) edit your /etc/lilo.conf file to refer to the new kernel?
2) run lilo once?

If you didn't, then it might be possible that all this time, your old kernel was been booted (no matter what you select at lilo), and since you overwrote the old modules with the new 2.2.13 modules (make modules_install), neither kernel could find the correct modules.

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Question has a verified solution.

Are you are experiencing a similar issue? Get a personalized answer when you ask a related question.

Have a better answer? Share it in a comment.

Join & Write a Comment

In the first part of this tutorial we will cover the prerequisites for installing SQL Server vNext on Linux.
Cron is one of the most popular and basic utilities found on Unix systems. Combined with other tools, cron makes it exceptionally easy to automate a broad range of tasks on your server.
Learn how to find files with the shell using the find and locate commands. Use locate to find a needle in a haystack.: With locate, check if the file still exists.: Use find to get the actual location of the file.:
Connecting to an Amazon Linux EC2 Instance from Windows Using PuTTY.

600 members asked questions and received personalized solutions in the past 7 days.

Join the community of 500,000 technology professionals and ask your questions.

Join & Ask a Question