[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 346
  • Last Modified:

Can't Print...queue is full

--------------------------------------------------------------------------------
I am having a problem printing. My print queue is full of print jobs. I am using Redhat 6.1. For some reason it cannot detect my parallel port. I was using Redhat 5.2 on this same box and it was printing fine until I installed 6.1. I can set up a printer (HP Deskjet using the printool) but all I ever get is a queue full of print jobs. The setup never detects the parallel port. Is there a file that I can edit to force the job to print ro a port? I know the port is good because I have a dual booted system using Caldera on the same box and it will print.
Any help would be appreciated.
0
madcrutch
Asked:
madcrutch
  • 3
  • 3
1 Solution
 
madcrutchAuthor Commented:
Edited text of question.
0
 
shimkoCommented:
You have to recompile the kernel from source code and configure support for parallel port devices. Read the HOWTO for rebuilding kernels. It's easy after you do it once.

Install the source from the distribution CDs and run make xconfig from the top directory.  look at each subsection to see what's included and not included by default.  once your happy with the configuration save it to a file.  Save and Exit.  

do:
make dep
make bzImage
make modules

then add these lines to /etc/lilo.conf  (just incase you need to boot the old kernel):
......<stuff from original file> .....
image=/boot/<put you kernel name here>
   label=<put a name here>
   <copy the device line from the original entry, sorry can't remember the specifics off-hand>
.....<your original first image entry --kernel >....

Save the revised lilo.conf.
then do:
make install
make modules_install


Then reboot.  If the kernel fails, reboot and select the second entry from lilo.  Press tab at the lilo prompt to see your choices.

0
 
madcrutchAuthor Commented:
Is there an easier less painful way to configure the parallel port? I am afraid that if I make the wrong move I'm sunk.
Thanks though, I will forge ahead with your suggestion.
0
The new generation of project management tools

With monday.com’s project management tool, you can see what everyone on your team is working in a single glance. Its intuitive dashboards are customizable, so you can create systems that work for you.

 
shimkoCommented:
I'll have to try something with my linux pc first.  Sorry, I can't think of any other way right now.
0
 
madcrutchAuthor Commented:
I tried to "make dep", "make config", "make mrproper"  etc... but every time I got this message
make:*** no rule to make target  'config' or 'dep' or 'mrproper'.
I looked through man pages and other resources but I am not sure of the command syntax. Could you help me with this?

Thanks in advance
0
 
shimkoCommented:
The first make command is "make xconfig" if your running Xwindows.  If you didn't untar the source you won't have the Makefile.
0

Featured Post

Free Tool: Subnet Calculator

The subnet calculator helps you design networks by taking an IP address and network mask and returning information such as network, broadcast address, and host range.

One of a set of tools we're offering as a way of saying thank you for being a part of the community.

  • 3
  • 3
Tackle projects and never again get stuck behind a technical roadblock.
Join Now