• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 254
  • Last Modified:

trouble w/ connecting to my ISP using kppp dialer

I set up a ppp connection, and when I try to dial it w/ kppp dialer, it says sorry, the modem is busy.  As far as I know, no other programs are using the modem.  I am running RedHat Linux 6.0, and the modem is a Conexant HCF V90 56K Fax PCI modem.  What am I doing wrong???

--Andy Moore
0
andy_moore1
Asked:
andy_moore1
1 Solution
 
andy_moore1Author Commented:
Edited text of question.
0
 
sirwnstnCommented:
First, check if you have a winmodem.  You can use this link to check.

http://www.o2.net/~gromitkc/winmodem.html

If your modem is in fact a winmodem, it's time to get a new modem.  No amount of hacking will allow you to use a winmodem with Linux (unless you steal the specs and source code from the company which is not nice).  
From the looks of it, your modem might be a winmodem.  If you need to get a new one, check the list or if you want to blow off the list, get an external modem- guarenteed non-winmodem.

(I am assuming you know how to fiddle with the kppp configurations)
When you do get a good modem in or hooked up to your machine, setting up kppp should be a snap.  Note the COM port the modem is using and configure accordingly in kppp.  COM1 is ttyS0, COM2 is ttyS1, and so on.  After you have set the correct port, you can check if kppp can talk to the modem by using the "query modem" button in kppp.  It should tell you what kind of modem you have and what not.  When that is done, you can now configure an ISP account for kppp to dial up to.  Most authentication now is PAP so set that option accordingly.  If you can't connect, try a different setting like CHAP.  If all of the settings fail to get you connected, check out this link:

http://axion.physics.ubc.ca/ppp-linux.txt

It's a very in depth How-To that will teach you the finer details of ppp on linux.  It teaches about connecting via command line, but it gave me some very valuable pointers to getting online.  Happy hacking.
0
 
andy_moore1Author Commented:
Just bought a new US Robotics modem, and I am nearly sure that it is not a winmodem.  Now, when I attempt to dial w/ kppp, it finds the modem, says "initializing modem" and does not go any farther than that.  I checked /var/log/messages for errors, and found the line "can't get terminal parameters: input/output error"
then it says chat script failed.  Now what am I doing wrong???


--- Andy Moore ---
0
Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

 
sirwnstnCommented:
It took me months to get ppp working for Linux.  If you're looking for a quick fix, I can't really offer that.  All I can say is, check the last link I showed you and hack on.  Good luck my friend.
0
 
andy_moore1Author Commented:
any ideas guys?
0
 
gregchavezCommented:
I also had a "winmodem", and "sirwnstn" is correct, NO CAN DO.
I dug around my garage and found a 33.6 ISA modem w/jumpers.  I picked IRQ 3 and COM4 and installed in my last ISA slot.  KPPP configured on the first try! (make sure you choose "cua3" since Linux reads this as COM4).  I guess what I am saying is that if your new modem has jumper settings, your chances of getting Linux to recognize the modem is improved.  
Hint:  Sometimes tty10 works instead of cuaX.

I don't know if this helps, but good luck!
0
 
sirwnstnCommented:
Andy,

      I'm sorry to say this again, but do you have a winmodem?  You didn't answer the question earlier,  so I am left to wonder.  Check this link:
      http://www.o2.net/~gromitkc/19991118a.html

I understand that it's a little overwhelming to scour this link for information, but a little persistence pays off.  You say you have a brand new USR modem but, that doesn't mean it's not a winmodem.  If it's internal, you can't really tell.  If it's external, it's guaranteed not to be a winmodem.
      You could get an old 14.4 external modem and hook it up to see if kppp can query it.  The key word here is "external."  If it works, you know soemthing's up with the other modems (either they are winmodems or there are IRQ and/or I/O conflicts).
      Greg is also correct when he said to use cua3 for COM4, but after reading the how-to from the axion link, I found out that they are slowly moving from cua to ttyS.  In either case, if they both show up in your /dev directory, you can use either.  I tend to favor the later ttyS devices, just because.   Anyways, I hope I didn't beat a dead horse, but really, take a step back and check to see what you have.  Then follow the advice we have given you.  
      If all this stuff is driving you nuts, spell out everything in detail for us- ie. what equipment you have: model numbers and what not, what you did with your stuff: plugged into what port or slot, and what commands you used, buttons you clicked, files you modified, or configurations you made.  Hopefully we'll have you surfing the web on Linux real soon.  Happy hacking.
0
 
biardCommented:
andy_moore1:

I had similar problems configuring my US Robotics modem to dial out through Linx Red Hat 6.0.  It is a Courier I V.everything 56K.  Definitely not a winmodem.  I set the jumpers on the modem to register on com 2, irq 3, which I had freed up in the system bios by disabling the onboard serial port (com 2).  This ensured no conflicts existed, but the problems I was having persisted.  I checked the /var/log/messages file, and I found that there were input/output errors, and an inability to open the requested port occured.  I had set the port to ttyS1, which should direct to com 2, but I eventually found that it actually was failing to do so.  I began to play with the tty seeting by thrying the other 3 possibilities (i.e. ttyS0, ttyS2, ttyS3) until I actually got a dial tone and was successful.  To this day, my modem is jumpered to a different port than my ppp is set to register to, but it is the only way I could get it to dial.  

Also, you might try just using the network configuration control panel.  I had much more success using that than any other tool.  Even linuxconf's tool was lacking in efficiency with ppp configuration.

Good luck!
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now