WfW and 3COM Card Problem

I have just installed a 3Com Etherlink II card in my WfW 386, gone through the installation dialog and restarted the computer. The command net start failed until I changed the config.sys entry from :-
   DEVICEHIGH /L:1,4560 =C:\WINDOWS\IFSHLP.SYS
to
   DEVICE=C:\WINDOWS\IFSHLP.SYS

Now the net start says it was executed successfully but I still don't get any response from my WinNt system. So when I type in
   
   NET VIEW

it says that it gets a syntax error in Protocol.ini (MAC005 error) which I cannot understand. Here is the complete Protocol.ini :

[network.setup]
version=0x3110
netcard=ms$elnkii,1,MS$ELNKII,3
transport=ms$ndishlp,MS$NDISHLP
transport=ms$netbeui,NETBEUI
transport=ms$nwlink,NWLINK
lana0=ms$elnkii,1,ms$netbeui
lana1=ms$elnkii,1,ms$ndishlp
lana2=ms$elnkii,1,ms$nwlink

[protman]
DriverName=PROTMAN$
PRIORITY=MS$NDISHLP

[MS$ELNKII]
DriverName=ELNKII$
MAXTRANSMITS=12
INTERRUT=10
IOADDRESS=0x300
TRANSCEIVER=onboard
INTERRUPT=5

[ELNKII]
Adapters=MS$ELNKII

[MS$NDISHLP]
DriverName=ndishlp$
BINDINGS=MS$ELNKII

[NETBEUI]
DriverName=netbeui$
SESSIONS=10
NCBS=12
BINDINGS=MS$ELNKII
LANABASE=0

[NWLINK]
BINDINGS=MS$ELNKII

and the sections from SYSTEM.INI :-

[Network]
FileSharing=Yes
PrintSharing=Yes
winnet=wfwnet/00025100
multinet=nonet
LogonDisconnected=Yes
EnableSharing=Yes
UserName=BIGRAT
Workgroup=WORKGROUP
ComputerName=WOODCHUCK
Comment=BigRat
logonvalidated=no
AuditEvents=3FF
AuditEnabled=1
AuditLogSize=4
AutoLogon=Yes
StartMessaging=Yes
LoadNetDDE=Yes
LMLogon=0
Priority=110

[network drivers]
devdir=C:\WINDOWS
LoadRMDrivers=No
netcard=elnkii.dos
transport=ndishlp.sys
LVL 27
BigRatAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

MATTCEICommented:
If this is a true copy-paste of your Protocol.ini file,then the line 'INTERRUT=10' is most likely the problem.Were you trying to manually edit this?

Since the IRQ is again defined two lines after this,you should delete this entire line.Also verify that the card is in fact set to IRQ 5 and address 300.
0
BigRatAuthor Commented:
The protocol.ini is a true copy and paste. I'll manually remove the INTERRUT=10 and try it out. No, I did not manually edit this file. Only CONFIG.SYS. The card is set to 5 and 300 of course.
0
BigRatAuthor Commented:
So I tookout the offending line and Lo! I get another error message about that Netbeui or IPX must be started first. (When I enter NET LOGON WORKGROUP it says that the basic service is not running, asks if I want it started and then gives me the error message) Unfortunately I have left the bit of paper with the error number on it at home. The only thing (netwise) I have in CONFIG.SYS is the load of IFSHLP and in AUTOEXEC.BAT NET START.
0
Cloud Class® Course: CompTIA Cloud+

The CompTIA Cloud+ Basic training course will teach you about cloud concepts and models, data storage, networking, and network infrastructure.

MATTCEICommented:
Looks like you're running the network in real mode (even though protocol.ini seems to say otherwise) or the network isn't configured completely.

Go into network setup - network card and  verify that a protected mode driver is installed.If so,remove/re-install the NIC drivers.If still NG,remove/re-install 'Windows Network'.
0
BigRatAuthor Commented:
OK, I'll try that.

THe actual error message number was 7631
0
MATTCEICommented:
Ya know,if I bothered to read the entire post...

Your error message is due to trying to start a real-mode net with NET LOGON WORKGROUP after the protected-mode net is started.Protected mode gives you a network only when in Windows - hence the errors when in DOS.

The way you should be establishing network connections is with File Manager - Disk (Share...,Connect...) for media,Print Manager for printers.
                     
0
MATTCEICommented:
BigRat ???
0
MATTCEICommented:
Your error message is due to trying to start a real-mode net with
                     NET LOGON WORKGROUP after the protected-mode net is
                     started.Protected mode gives you a network only when in Windows -
                     hence the errors when in DOS.

                     The way you should be establishing network connections is with File
                     Manager - Disk (Share...,Connect...) for media,Print Manager for
                     printers.
                                         
0
BigRatAuthor Commented:
Sorry away with a rather nasty cold.

Now back. OK I accept the DOS point, but when I start WfW I get a NetLogon box but no possibility of "sharing" in file manager. Currently the only other machine is my WinNT 4.0 client, and it sees nothing either. I'm trying to get my Linux system up with Samba. But I have problems getting the Kernel correct for IDE boot but SCSI main disks. So I'll keep on trying unless you have any other ideas.

I have not forgotten you and have upped the points to 100 for your patience.
0
MATTCEICommented:
You may not have enabled sharing.
Look in Main - Windows Setup - Change Network Settings.
0
MATTCEICommented:
You may not have enabled sharing.
Look in Main - Windows Setup - Change Network Settings
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Windows OS

From novice to tech pro — start learning today.