getting a linux box on a network

I have 2 computers curently networked , and im trying to add a third. the problem is that i am another newbie with linux, and the first two systems are wim98.  If i can figure out linux, im going to convert all of them...

This is what ive done...

Ive installed linux on a old packardbell p75, and it seemed to go very smothly (after doing it about 8 times before, hehe)  I installed all the network stuff i could find in the install, and i can ping my NIC (ping 127.0.0.1) but i can not ping the other 2 systems.  I have tryed 2 NICs, with the same results.  The information that came with both NICs say to use the tulip driver that comes with linux.  The NICs i tryed are from Netgear, and Unicom.  I have used both of them before with win98. I have had as many as 5 computers on my network, so the hub is ok...

My DNS is probably screwed up to, but that is not the question...  I dont get it, im getting "happy lights" from everything, why cant i ping?  

this is my network configuration:

isp:  pacbell.net getting dsl

1st computer: 10.1.1.94 (interal NIC) this one is resecving dsl on a second NIC and is running winproxy omega.pacbell.net

2nd computer: 10.1.1.93 ptwo.omega.pacbell.net This one gets the web very nicely from the first one.

3rd computer: (linux) 10.1.1.91 dumpy.omega.pacbell.net
kyvAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

kyvAuthor Commented:
Adjusted points to 60
0
kyvAuthor Commented:
Edited text of question.
0
rwenzlaCommented:
Pinging 127.0.0.1 doesn't check your NIC.
127.0.0.1 is the "loopback" device.  It always works.  It's strictly software.

Check the output of dmesg to make sure your ethernet card is being detected. command: "dmesg | more".

If the card is detected properly, make sure the interface is "up".  Use the ifconfig command.  You can use the command "ifconfig eth0 up" to bring it up if it's not. (RedHat has scripts "ifup eth0" and "ifdown eth0")

I don't know what distribution you have, but RedHat has a nice tool 'netcfg' for setting up the network.  If you don't have such a tool, then it's just a few lines added to /etc/rc.d/rc.local to bring the ethernet card up at boot.

You need to dectect the card, and if it's a modular kernel (most are) load the module for your card (I called it module.o, here)

/sbin/modprobe module.o [io=0xnnn,irq=m]

The parameters aren't needed for most PCI cards, they can be probed.

/sbin/ifconfig eth0 up


Then add to /etc/conf.modules

alias eth0 module.o

to tell the OS that this interface needs this module.

That should bring you to the ping stage.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

rwenzlaCommented:
I forgot the routing.  The netcfg can do it, but you should add a route for your local net.

/sbin/route add -net 10.1.1.0 netmask 255.255.255.0 eth0

The default route (0.0.0.0) needs to be set to tha address of your proxy box.
0
kyvAuthor Commented:
I shoud have said i an using redhat 5.1


That stuff seems like it is in the right direction, but i found exactly this information on another page, and tryed it.  the dmesg | more cammand shows that i have a eth0 on irq11.  ifconfig shows all of my ip info like (i think) it should.  and i love and netcfg, that is just a great program for its ease of use, and compleatness.  
i did not need "ifconfig eth0 up" (i dont think) because netcfg will activate the card and set it for me to be active at bootup...(yes, i tryed it anyway).

I added that line to the routing table, but it didnt seem to help.  I noticed that in the routing table the defaly gatway (my computer connected to the net) was listed there with the wrong netmask (it is 0.0.0.0) and i cant figure out how to chang this.  however, i dont think my gateway should be keeping me from pinging inside my network...
thx for the help...anyother thoughts?
0
kyvAuthor Commented:
oh, never mind about the mask being wrong on the gatway, i just read why it has to be that way...
0
kyvAuthor Commented:
this is NOT answered.
0
bjledetCommented:
this is not necessarily an answer..but i thought i would throw in my 2 cents. i have a similar situation as you do, 2 win98 pc's and a new linux test box as well.

win98 pc1 has a modem with sygate running on it, lan card too...using ip address 192.168.0.2  subnet 255.255.0.0

win98 pc2 has a lan card...ip address 192.168.0.3  subnet 255.255.0.0   gateway 192.168.0.2   dns server 192.168.0.2 this is the default setup for sygate on win98.

linux box has lancard   ip address 192.168.0.1  subnet mask 255.255.0.0   gateway 192.168.0.2    dns server is the ip of my isp dns server.
  i found linux would not pick up dns the same as win98 box.  i had to point it to the isp dns server for it to work..but once did that..now can surf the web just fine...  using mandrake 6.1 with linuxconf to setup all the paramters. using this setup, i can ping any and all systems in house and out of house.  
0
kyvAuthor Commented:
im not going to wory about the DNS untill i can ping because i dont think you need the DNS to ping, but you do need to ping for the DNS to work (please correct me if im wrong).  Our IP sceems are not really different:  we are both using non-internet IPs, and no reserved numbers.


I NEED HELP!!!!


I guess what i need to know is:  What should i start throughing out?  


The only thing i can figure is that linux is failing to see the pci bus, or the tulip modual is buggy.  Something is not working as it should, or im just missing a step in the setup.  Honestly, it doesnt look very much harder than setting up network suff on a win98 box, it just does not work!!! arg!!!
0
kyvAuthor Commented:
an update on my plight:

when i ping the win98 boxes from the linux box, the hub is showing trafic only on the linux port.
when i ping a win98 to a win98 box, i get trafic from both ports.  This says to me that i have overlooked a tcp/ip step.  I just have no idea what it could be.  ifconfig shows all the right stuff:

link encap:ethernet hwaddr 00:a0:cc:52:23:a1
inet addr:10.1.1.91 bcast:10.1.1.255 mask:255.255.255.0
up broadcast running multicast mtu:1500 metric:1
rx packets:0 errors:0 Droped:0 overruns:0
tx packets:51 errors:0 Droped:0 overruns:0
interrupt:11 baseaddress:0xfc00

the win98 boxes have the same mask, and the IPs are: 10.1.1.94 and 10.1.1.93
do i have to do something to the win98 boxes to get them to see the linux ping?
after boot, linux is also giving the error message:

httpb: can not determin local host name.  Use ServerName to set it manually.

that is all and good, but i can not find ServerName in order to run it, so i check ifconfig and route again and...

and whe i run route, it hangs after displaying the network, the lo...i guess the gw is confusing route? if i del the gw, and then add it again, it will show it to me, no problems, untill i reboot.
0
bjledetCommented:
im just starting too..but since mine is working...maybe we can fight this together...if this is allowed...send email to bjledet@bellsouth.net.  ill do what i can with you...
0
kyvAuthor Commented:
to clarify what i was saying about route hanging, it returns:

Kernel IP routing table
destination  Gatway  Genmask           Flags  Metric Ref use Iface
10.1.1.0       *            255.255.255.0  U        0         0   1      eth0
127.0.0.1     *            255.0.0.0          U        0         0   1      lo

then nothing untill i hit ctrl-c

if i enter:

route del 0.0.0.0
route

destination  Gatway  Genmask           Flags  Metric Ref use Iface
10.1.1.0       *            255.255.255.0  U        0         0   1      eth0
127.0.0.1     *            255.0.0.0          U        0         0   1      lo

and gives me the prompt, so i contiued with:

route add default gw 10.1.1.94 eth0
route

destination  Gatway               Genmask           Flags  Metric Ref use Iface
10.1.1.0       *                         255.255.255.0  U        0         0   1      eth0
127.0.0.1     *                         255.0.0.0          U        0         0   1      lo
default         omega.pacbell.n 0.0.0.0              UG      0         0   0      eth0
and gives me the prompt

how does it know that 10.1.1.94 is omega.paccbell.net if it can not ping anything?  netcfg could have saved that setting somewhere i guess...
0
rwenzlaCommented:
To ease your headaches, use 'route -n' until you're sure the DNS is up.  This is why it hangs.  It's trying to fill in the names.  '-n' says just give me the numbers.

Have you tried pinging the linux box from the Win boxen and whatching the hub lights?  It sounds like they might not be routing packets back.  "tx packets: 51, rx packets:0"

If they don't recognize the IP as on the local net, they might be [trying to] send the packets out the dsl interface (the 10... would stop them, though).

Check /etc/hosts I bet thats where netcfg put the GW name.

Check the windows boxes routing tables "route PRINT".
See if there's a route that will catch the IP for your linux box.  You'll have to parse them carefully, Win doesn't orgainize them very well, and it displays them bottom (most specific)up (default gw).


0
kyvAuthor Commented:
thx for the tip on route -n, ill use that...

yes i did ping the linux box from the win98 box, and the lights did show trafic only on the win98 port.

i did a (kinda) sneeky thing.  I tryed the IP that im tryin to asign the linux box, in one of the win98 boxes (ptow.omega.pacbell.net), and i had no proble pinging it (from omega.pacbell.net), so it does not think that IP is out the dsl NIC.
however, this was the output of route print:

Active Routes:

  Network Address   Netmask             Gateway Address  Interface        Metric
          0.0.0.0          0.0.0.0                 83.194.77.254       83.194.77.77   1
         10.1.1.0         255.255.255.0     10.1.1.94               10.1.1.94         1
        10.1.1.94        255.255.255.255 127.0.0.1               127.0.0.1         1
   10.255.255.255   255.255.255.255 10.1.1.94               10.1.1.94         1
      83.194.87.0      255.255.255.0      83.194.77.77         83.194.77.77  1
     83.194.87.60     255.255.255.255  127.0.0.1              127.0.0.1         1
   83.255.255.255   255.255.255.255   83.194.77.77        83.194.77.77  1
        127.0.0.0        255.0.0.0              127.0.0.1               127.0.0.1        1
        224.0.0.0        224.0.0.0              10.1.1.94               10.1.1.94        1
        224.0.0.0        224.0.0.0               83.194.77.77         83.194.77.77 1
  255.255.255.255  255.255.255.255   83.194.77.77         0.0.0.0           1

i dont see any problems here, but im no exspert  (lol, or i would have answered questions, not asked them)      :]

0
kyvAuthor Commented:
you should know that i did put the IP addresses back to the correect box, so that they still refect the information i have given.
0
kyvAuthor Commented:
this is a very long message i will forward here that clarifys some points...


> Second comment: So... what sort of setup _has_ been
> done on the ethernet NIC? Does the kernel show that
> the NIC is detected (i.e. the driver loads and
> detects the NIC)? If not, how are you loading the
> driver? Are you passing the proper parameters to it?
> For example (from /etc/rc.d/rc.modules in _my_ setup):
>     /sbin/modprobe tulip options=1

in the installation of redhat, it asked what kind of NIC i have, and many
other questions about it.  what was not entered here, i have mostly put in
though over GUI programs that came with redhat  (ie:  netcfg, and linuxconf)
i also added a route in the routing table to show the local network  on the
advice of someone else.i did it like this:

route add -net 10.1.1.0 nm 255.255.255.0 eth0        if i remember all of
it...


>
> Do you 'ifconfig' the NIC somewhere (i.e. in one of
> the /etc/rc.d scripts)? How about the route commands
> for the NIC (route add -net / route add -host / etc)?


the above progams setup the scripts, i think....everytime i boot the linux
box, it has the settting in ifconfig, and route without me entering them
each time.  am I under some misperception?



> Third comment: could it be something more fundemental,
> like wiring? How are the NICs wired together? Do you
> use 10Base5, 10Base2, 10BaseT or 100BaseT? If 10BaseT
> or 100BaseT, are you wired point-to-point or through
> a hub? If point-to-point, do you use cross-over cable?
> If through a hub, do you use straight-through cable?
> Catagory 3 or 5?
> Have you done a contenuity check on the cable (no
> broken wires, proper resistances, proper pinouts)?
> OK, so maybe it's the hub that's at fault. Try swapping
> the 10.1.1.91 and 10.1.1.93 ports (plug 10.1.1.91 into
> the hub slot where 10.1.1.93 is now, and put 10.1.1.93
> into the slot where 10.1.1.91 vacated) and try pinging
> again. Watch for the hub lights and give us a sign.
>

all wires are cat5, and i interchangded them 4 times, to check that they are
all working, and i have swaped the ports on the hub many times.  I have a
cross-over cable somewhere, but it is yellow, i didnt put it on the hub.
All NICs are 10/100, and the hub is only 100.



> Fourth comment: A diagram would be helpfull. Something like...
>



    ADSL
            \-------------
             |   ?.?.?.?  |
             |  Omega  |
             |   win98   |
             | 10.1.1.94|
             -------------\
                              \
                                < 8 port 100 hub>
                                    |                |
                                   /                 \
                                  /                    \
                 -------------/                       \-------------
                 | 10.1.1.93|                        |10.1.1.91 |
                 | ptwo       |                        | dumpy    |
                 | win98     |                        | redhat 5.1|
                 -------------                        --------------




> Excellent advice. One comment here: the tulip driver takes
> slightly different options. It's best to read the remarks
> in the tulip.c source code, but tulip.c:v0.89H 5/23/98
> seems to take options in the form of
>      "options=#[,#...]"
>      "full_duplex=#[,#...]"
> and  "mtu=#[,#...]"
> The only one I use is "options=" to define the connection
> (in my case 10Base2) for the NIC.
>




ok, i think this might be the right diretion, because i had no idea that was
true, and i dont quite understand how you are suggesting i add the opoins.
All of my NICs are 10/100, but my hub is only 100 (i didnt have the cash for
the 10/100 hub). could it be that the tulip mod is only letting the NIC
transmit it 10baseT?





>
>
> FWIW, Win98 can accept additional (nonstandard) information from
> a PPP connection which provides a dymanically assigned DNS for
> the connection. The last time I looked, pppd doesn't accept this
> nonstandard information when on the 'client' side of a PPP connection
> (although it _can_ provide a dynamic DNS from the 'server' side
> of a PPP connection). You have a few options in linux, though:
> You can 1) hardcode the dns addresses in /etc/resolv.conf, or
>         2) you can run your own caching DNS server on Linux
>            and not care what your ISP's dns is, or
>         3) assuming you have a real domain name, you can run
>            a full DNS server on Linux, and _really_ not care
>            what your ISP's dns is
>


doesnt the proxy running on omega take care of this?


> >
> Another comment: Can you ping your NIC from Linux? I.e.
> have Linux ping 10.1.1.91?

yes


> That's somewhat good news, at least your Linux NIC is
> working and the cable to the hub is OK. What to you
> see when you ping the linux box from one of the Win98
> boxes?
>

I get traifc on only the win98 side


> > when i ping a win98 to a win98 box, i get trafic from
> > both ports.  This says to me that i have overlooked a
> > tcp/ip step.  I just have no idea what it could be.
> > ifconfig shows all the right stuff:
> >
>
> You don't have your hostname set. Use the hostname and dnsdomainname
> to set your Linux host name.

when i type in hostname, it returns:
dumpy.omega.pacbell.net

dnsdomainname just hangs

> It would also help to see...
>   - your ifconfig stmts on Linux


lo         link encap:Local Loopback
            inet addr:127.0.0.1bcast:127.255.255.255 mask:255.0.0.0
            up broadcast loopback running mtu:3584 metric:1
            rx packets:56 errors:0 Droped:0 overruns:0
            tx packets:56 errors:0 Droped:0 overruns:0

eth0      link encap:ethernet hwaddr 00:a0:cc:52:23:a1
            inet addr:10.1.1.91 bcast:10.1.1.255 mask:255.255.255.0
            up broadcast running multicast mtu:1500 metric:1
            rx packets:0 errors:0 Droped:0 overruns:0
            tx packets:51 errors:0 Droped:0 overruns:0
            interrupt:11 baseaddress:0xfc00


>   - your route stmts on Linux

Destination    gateway    genmask          flages  metric  ref  use  iface
10.1.1.0        *              255.255.255.0   U         0       0     1
eth0
127.0.0.0      *              255.0.0.0           U        0       0     2
lo
default          omega.pacbell.net  0.0.0.0   UG     0       0     13   eth0


>   - your modprobe / conf.modules stmts on Linux

im probably showing my newbieness here, but when i enter:
modprobe /conf.modules
i get:
no dependacy information for module: /conf.modules

>   - your dmesg or /var/log/messages

dmesg is quite lage, and i think what you are loooking for is this line:
eth0: Lite-On 82c168 PNIC at 0xFc00, 00 a0 cc 52 23 a1, IRQ 11

and when i try to acsess var/log/messages, i told that "permission denied"
even when loged on at root.  (i acually have not even made any "users" yet
because if i can not get it on the net, there is no reason to keep it)

>   - your routing table on Linux and the Win98 boxen

from omega (edited)
  Active Routes:
Network Address        Netmask             Gateway     Interface  Metric
         0.0.0.0                0.0.0.0                ?.?.?.?      ?.?.?.?
1
         10.1.1.0              255.255.255.0      10.1.1.94 10.1.1.94      1
         10.1.1.94            255.255.255.255  127.0.0.1  127.0.0.1      1
         10.255.255.255   255.255.255.255  10.1.1.94  10.1.1.94      1
         ?.?.?.?                 255.255.255.0     ?.?.?.?       ?.?.?.?
1
         ?.?.?.?                 255.255.255.255  127.0.0.1  127.0.0.1
1
         ?.?.?.?                 255.255.255.255  ?.?.?.?       ?.?.?.?
1
        127.0.0.0             255.0.0.0             127.0.0.1   127.0.0.1
1
        224.0.0.0             224.0.0.0             10.1.1.94   10.1.1.94
1
        224.0.0.0             224.0.0.0             ?.?.?.?        ?.?.?.?
1
        255.255.255.255  255.255.255.255   ?.?.?.?       0.0.0.0        1

from ptwo
Active Routes:

  Network Address Netmask            Gateway    Interface  Metric
          0.0.0.0        0.0.0.0               10.1.1.94  10.1.1.93       1
         10.1.1.0       255.255.255.0     10.1.1.93  10.1.1.93       1
        10.1.1.93      255.255.255.255  127.0.0.1  127.0.0.1       1
   10.255.255.255  255.255.255.255  10.1.1.93  10.1.1.93       1
        127.0.0.0      255.0.0.0             127.0.0.1  127.0.0.1       1
        224.0.0.0      224.0.0.0             10.1.1.93  10.1.1.93       1
  255.255.255.255 255.255.255.255  10.1.1.93   0.0.0.0          1

from dumpy:
Destination    gateway    genmask          flages  metric  ref  use  iface
10.1.1.0        *              255.255.255.0   U         0       0     1
eth0
127.0.0.0      *              255.0.0.0           U        0       0     2
lo
default          omega.pacbell.net  0.0.0.0   UG     0       0     13   eth0



>   - some details about your hub

8 port fast ethernet hub

>
>
> --
> Lew Pitcher
>
> Master Codewright and JOAT-in-training

respond from kyv
Apprentice linux user, power win user
:]

0
rwenzlaCommented:




>ok, i think this might be the right diretion, because i had no idea that was
>true, and i dont quite understand how you are suggesting i add the opoins.
>All of my NICs are 10/100, but my hub is only 100 (i didnt have the cash for
>the 10/100 hub). could it be that the tulip mod is only letting the NIC
>transmit it 10baseT?

I think you might be onto something here.  I scanned the tulip.c file and about line 35 they talk about selecting media type in the options= settings.  Try adding a
"medianame=100baseTx" to your options. Look in the tulip.c file for the options.
0
rwenzlaCommented:
add the options as a parameter to your modprobe command.

/sbin/modprobe tulpip.o medianame=100baseTx
0
kyvAuthor Commented:
ok, i have good news, and i have bad news:

the good news is that i barrowed a 3com NIC, and i worked right away.
the bad news is that i have to return it.  

This means to me that the tulip mod is not working.  I got the options working, but that did not help.  I tryed to get the latest ver of tulip from netgear, but i can not get it working.   During all this i switched to mandrake 6.5, but i was told it is based on RH, and changing this only made things look better, not work any differenty.  so how do i get the new tulip.c to work?  when i compile it with the command they give, i get 2 errors. they are both something about using brackets, and not the "else". if i use the new tulip.o anyway, i get more than a page of errors, most of which have to do with things being unresolved.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux Distributions

From novice to tech pro — start learning today.