Keywords Field doesn't display results on seperate lines

Hello,

I have a field which is set to Keywords and allow multi values (as well as allow values not in list)  When the user selects multi values they are seperated by a comma and don't appear on sepearate lines like I wish them to.

How can I get a User to select from pre decided list (not calculated its a static list) and have the results in the field appear seperated by a new line.

Hope this request makes sense

Thank you

Rhomulos
LVL 2
rhomulosAsked:
Who is Participating?
 
ArunkumarConnect With a Mentor Commented:
Keep one field with whatever you need to have. Editable Keywords allow multivalues etc.,.  

* Note that you dont have the option to display the list selected in a separate line.

Keep another field below that field.  Let it be computed allow multivalues with new line as separator.  Let this computed field has a value of the previous fields Name.

Now,

Write a hide when formula to both of these fields. Editable one with the

!@IsdocbeingEdited

And the computed one with

@IsdocbeingEdited.

This was the solution that I was able to give to my customer because you dont have anyother option to display keywords fields in a new line separator.

:(
Arun

PS: I dont have a template since I am now with a differemt company in a different Country !
0
 
AntonysinghCommented:
Hi,

In field property , select option tap, then in "Display separate valus with " option select "New Line", the option "separate values when user enter" should be comma, semi colon. Finaly you have refesh(F9 or any other command to refresh the form) the form to get the multivalue in separate line.


Regards,
Antony.
0
 
ArunkumarCommented:
Waiting to give the right answer !!!

-Arun
0
Take Control of Web Hosting For Your Clients

As a web developer or IT admin, successfully managing multiple client accounts can be challenging. In this webinar we will look at the tools provided by Media Temple and Plesk to make managing your clients’ hosting easier.

 
rhomulosAuthor Commented:
Sorry already tried that, the particular option is greyed out.
As I suspect Arun was aware. :-)
0
 
ArunkumarCommented:
COOL Rhomulos!  

Take this link I had asked this question on EE a couple of months before.

http://www.experts-exchange.com/jsp/qShow.jsp?ta=lotusnotes&qid=10186248 

Sorry to hook you on to another link.

You will lose only one point.  The discussion is worth spending point.

Good Luck !

*Smile*

-Arun


0
 
rhomulosAuthor Commented:
Sorry,

Read the previous question, One point is no problem,  but still not entirely clear on the answer.

Could you email me a one form NTF possibly so I can see it in action or can you list the script code you used to populate one field from another?

I haven't done any real notes developement for about 18 months and even back then I wasn't any good so better use the dummy gloves on me.

Rhomulos
0
 
rhomulosAuthor Commented:
Hi Arun,

I got off my lazy butt and actually tried, worked first time was obvious once I tried to do it.

Please post another answer so you can have the points.

Thank you

Rhomulos
0
 
rhomulosAuthor Commented:
Thanks for that, I used the ticks instead of the formula (If it becomes a problem I will use a formula)

It works very well on initial tests though.
0
All Courses

From novice to tech pro — start learning today.