Gnome and XF86 problems

I've got RedHat 6.0 running on my Compaq Armada 7400 laptop (runs great by the way). I thought I finally found the right X server for my LCD screen.

1) Any idea why I'm getting junk when I run Gnome? I can vaguely see windows but can barely read any text. Is it just the wrong X server?

2) Because I couldn't see what I was doing the first time I ran Gnome, I accidentally set X Windows to run every time I start Linux. Anyone know how to turn this off? How do I startup without X starting? (it's going to be difficult to edit any files in X when I can't see what I'm doing!)

Gracias!!!
troAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

DVBCommented:
I'm assuming you are using lilo.
At the lilo prompt, type:  linux single.
This will take you to single user mode.
Edit the file /etc/inittab.
Change the line with default runlevel. Replace the 5 by 3.
This will let you work from the command prompt.
0
drittichCommented:
What X server are you using, and what video card are you selecting when configging X?
0
mrcmillerCommented:
Replacing the default runlevel 5 with a 3 may not do it.  Some setup programs add xdm support (xdm causes X to load when you start Linux) to runlevel 3.  If you find your default runlevel is already 3 or you change it to 3 and it still loads X, go into /etc/rc3.d and move S99xdm to your home directory or delete it completely.  If you move it to your home directory, it will be easy to put it back if you decide you like the xdm login screen.  

As for your server, I'm with drittich; we can't help you until we at least know what card you told the setup program you have.  

Does X work okay when you're not using Gnome?
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

DVBCommented:
Redhat 6.0 uses runlevel 3 for textmode. I used it till a couple of days back (I upgraded to 6.1).
On the video card, I'm with drittich. Please give a lot more details.
0
bernardhCommented:
you can try other desktop managers by running the command 'switchdesk'. or you may edit the /etc/inittab and replace id:5:initdefault: with id:3:initdefault: it always work with redhat 6.0.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
troAuthor Commented:
Changing the 5 to a 3 worked. Thanks to DVB and bernardh. Since I can't figure out a way to award the points to DVB, bernardh gets 'em.
0
DVBCommented:
There is a accept comment as answer option available.
Otherwise you could have asked me to put up an answer after rejecting the given answer.
I don't mind bernardh getting the points, but these are two possible methods of giving answers to the right person.
DVB
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.