• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 322
  • Last Modified:

Recompile Kernel

OK...I have Mandrake Linux 6.5 but have a USB Logitech Wingman Gaming mouse.  I went and downloaded a 2.3.x kernel (yes I know it's experimental, blah blah blah---I'm not new to computers, just to linux, and it's a dual boot system, not too worried).  I am having trouble compiling the kernel- I think.  I to a make config, then a make dev, then a make zImage.  make zImage does not finish---I get an error, the first time it was in the FS (file system?) section...redid make config with some different options, re did make dev, make zImage.  still won't work.  Tried several different configurations, still not getting anything.  Anybody know of an easier way to get USB mouse support?

Last lines on screen:
      drivers/block/block.a drivers/char/char.a drivers/msic/misc.a
drivers/net/net.a drivers/cdrom/cdrom.a drivers/sound/sound.a drivers/
pci/pci.a drivers/pnp/pnp.a drivers/video/video.a drivers/block/paride
/paride.a drivers/usb/usb.a \
      /usr/src/linux/arch/i386/lib/lib.a /usr/src/linux/lib/lib.a /u
sr/src/linux/arch/i386/lib/lib.a \
      --end-group \
      -o vmlinux
fs/filesystems.a(fat.o): In function `fat_file_write':
fat.o(.text+0x271b): undefined reference to `update_vm_cache'
fs/filesystems.a(smbfs.o): In function `smb_get_dirchache':
smbfs.o(.text+0x3511): undefined reference to 'get_chached_page'
smbfs.o(.text+0x3569): undefined reference to 'get chached_page'
fs/filesystems.a(smbfs.o): In function `smb_add_to_cache':
smbfs.o(text+0x3720): undefined reference to 'get_cached_page'
make: *** [vmlinux] Error 1

NOTE:  I copied these "manually"...double checked them but they may be slightly inaccurate.  HOpe this helps!
0
horowitz111199
Asked:
horowitz111199
  • 2
1 Solution
 
mwnCommented:
Can you give us, say the last 20 lines from your attempt to make a kernel, ie. make zImage ?
0
 
horowitz111199Author Commented:
Edited text of question.
0
 
strmtrprCommented:
I don,t know if this will help, but after you finsih configuring your kernel:

make dep
make clean
make zImage

and if you bulit any modules

make moudules
make modules_install

just a thought.
0
 
mwnCommented:
It looks like to me that you have configured your kernel wrong !

I think your problem is with the Filesystem configuration ...
0

Featured Post

[Webinar] Kill tickets & tabs using PowerShell

Are you tired of cycling through the same browser tabs everyday to close the same repetitive tickets? In this webinar JumpCloud will show how you can leverage RESTful APIs to build your own PowerShell modules to kill tickets & tabs using the PowerShell command Invoke-RestMethod.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now