partition problem

Originally, I installed Redhat 5.2 on my system from a cd, and after the installation, I restarted my computer.  Lilo boot, however, never came up.  I decided to just delete the partitions, and tried to convert them back to dos partitions.  As soon as I deleted the linux partition, though, fdisk nor  disk druid will recognize it.  Essentially, it seems like the .5 gig of disk space is missing.  Disk druid tells me that I have 503 mb max space free but it won't allow me to create a partition of that size.  it says not enough space...can anyone help?????
anthonyc01Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

BigRatCommented:
It sounds as if the hardware formatting has got corrupted. The only way to reformat the disk is to send it back to the manufacturer. Perhaps reposting this question in the Hardware area may bring more success. It was almost definitely not the Linux installation which caused this. Perhaps you once dropped the disk(?).
0
raks04Commented:
hey man one thing is for sure your disk is screwed somehow
this kinda stuff rarely happens in linux!!
as for disk druid try sizes slightly less or more than 503mb
it worked for me!
as for the rest of the probs wait a couple of days i'll see what i can do
0
drittichCommented:
If neither Disk Druid nor fdisk are showing you all of the available space you should be seeing, then the drive is corrupt.  Here are a few things to check:

1. Make sure the BIOS settings for the drive are right.

2. Low-level format the drive.  If you don't have a utility for this, go to

http://www.seagate.com/support/disc/faq/faq96029.shtml

where you will find instructions on doing this using yuor BIOS, or with a utility that you can download from the site.

3. How many drives are in your system?  Are you sure you are looking at the right one?  It happens...
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

toby102299Commented:
Try this first if your total drive space is < 2GB.  Otherwise, skip to the paragraph after the next one (the third paragraph that discusses low level formatting).

You may want to boot the PC with DOS and then use the DOS FDISK utility to try to delete the partitions that show up as UNKNOWN.  However, if you had several Linux partitions (which is usually the case), be advised that they might all  show up as this one UNKNOWN partition.  Delete this partition and then repartition it as DOS.  I would then install DOS on the drive and perform a CHKDSK.  Count the total bytes.  If you've regained the missing .5 GB then everyting is cool.  The you can re-run Disk Druid and re-install Linux. NOTE: DOS only recognizes drive sizes of 2 GB or less. Drives larger than 2 GB must be formatted into multiple partitions.

Check your computer specifications for the drive type that was included with your PC.  Then, contact the manufacturer or search the web for utility software that will allow you to do a 'low level' format of the drive.  After performing the low level format, all high level partitions (DOS, NT, Linux, OS/2, whatever) will be removed from the drive.  

Reboot the PC and go into the BIOS.  Check and verify that the drive settings are correct for you drive.  If they are not, add the correct information (Cylinders,Heads,etc).  

Now, run Disk Druid or FDISK to repartition your drive.  Re-install Linux.

If your drive fails again after you've performed the low level format, linux format, and re-install, then you might want to replace the drive as it is probably broken.



0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rwenzlaCommented:
The blocks shown in disk druid are rounded off.  Sometimes it will say 503MB but really only have 502. . .

I prefer the linux fdisk command, because it lest you see the actual block sizes.
0
xemaCommented:
I had a similar problem, I'm into dual boot win 95/linux.
Use linux fdisk NOT disk druid to set your partition, then use disk druid to set the mount point
0
pc_bCommented:
Boot up in Dos and at the prompt ie C:> type "fdisk /mbr" without the quotation marks. Nothing will seem to happen, but reboot and see if that resolves your problem. I also agree with xema's suggestion, use fdisk and not disk druid.   Please note that it is recommended that you should use the same fdisk to delete a partion as you used to create it. i.e. if created in Dos, use Dos FDISK to delete, If created using Linux fdisk, use Linux fdisk to delete it.   In otherwords if you have deleted a partion using another operating fdisk, recreate it using that one, then delete it using the other operating system. Hope you can make sense of all that.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.