Mount:Can't find dev/fd0

When I try to access my floppy drive, I get : Could not mount.  Mount:can't find dev/fd0 in etc/fstab or mtab.  I am currently running Red Hat 6.0 with gnome and kde.  Also, how can I access the floppy when I am a user?
ringtbAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

laeuchliCommented:
to mount try this. frist for one time only you have to have a floppy directroy. So type mkdir floppy.
Then type mount /dev/fd0 /floppy
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
rwenzlaCommented:
to access the FD as a user, make sure the "user" directive
is on the floppy drive entry in the file  /etc/fstab

/dev/fd0  /floppy  auto    noauto,user  0 0

I like the /floppy as a mount point, but the default location is /mnt/floppy

In either case, as laeuchli said, the directory must exist.
0
holyrailCommented:
Hey there.

I had a similar problem. First make the mount point dir (the point where Linux will put the files that are on the floppy) For example, /mnt/floppy - it may already be there- check it out in GNOME under LinuxConf > local drives.

I then exited GNOME and was at the command line as root. Then I mounted the floppy as a msdos type first instead of the ext2 (didn't have a Linux formated disk - chicken&egg)

To mount I typed:  mount -t msdos /dev/fd0 /mnt/floppy
and make sure YOU HAVE A DISKETTE IN THE DRIVE (I had an IBM formated -ie msdos)

The floppy drive engages for a few seconds. It should be mounted. I then went back into GNOME, went to LinuxConfig > local drives - and sure enough the floppy was mounted - hot damn!!

Next, You'll need to format a floppy for use with Linux - In GNOME look under the main menu for the KDE options - there is one that says something about floppy. select the ext2 type instead of msdos - press ok. bingo you are ready to role!!!

Good luck,

Ron
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.