[Webinar] Streamline your web hosting managementRegister Today

x
  • Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 198
  • Last Modified:

Apache web server

This is what I have in access.conf :

<Directory /home/tanc02/web-docs/mcs/>
 AuthName  NEW
 AuthType Basic
 AuthUserFile /home/tanc02/web-server/.1234567890
 <Limit GET>
 require valid-user
 </Limit>
</Directory>

And why sometime, it asks the user name and password twice ?
Anything wrong ?

Should I have this :

<Directory /home/tanc02/web-docs/mcs/>

or this :

<Directory /home/tanc02/web-docs/mcs>
0
allquest
Asked:
allquest
  • 3
  • 2
1 Solution
 
gunny051499Commented:
if you are accessing a subarea of this with another (different passwort) and change back, it could cause you to be asked for it again (btw. you can take out the require parameter from the limit-brackets).

the later does not affect apache.
0
 
allquestAuthor Commented:
can you be more specific ?
0
 
gunny051499Commented:
well you have the following:
<Directory /home/tanc02/web-docs/mcs/>

it may be, that you have also something like:
<Directory /home/tanc02/web-docs/mcs/subdir>
or like:
<Directory /home/tanc02/web-docs/>
being protected by a different passwort and/or username at the same time. this would cause you the effect described by you and is to be seen as a correct effect.

also i meant that you don't need to put in:
<Limit GET>
require valid-user
</Limit>
which usually shouldn't make sense, but just:
require valid-user

0
 
allquestAuthor Commented:
It still ask me twice for password and username.
And I only have one password file and there isn't any subdir in mcs. Why ?
0
 
gunny051499Commented:
any caching systems in the middle?
0

Featured Post

Never miss a deadline with monday.com

The revolutionary project management tool is here!   Plan visually with a single glance and make sure your projects get done.

  • 3
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now