Cannot use gnome or any gui correctly

When I login if I use gnome the display is too large as if on zoom, but functional..the other gui's provide only a blank screen the hard drive runs a little then all you can do is hit the off switch.
Avenger111199Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

Avenger111199Author Commented:
Is this the monitor settings or graphics card ...?
0
intheCommented:
run setup again from the prompt as root and change to the correct values the moniter and  video card settings .after specifying these reboot into gnome and use the "ctrl"&"alt"&"+" keys (or"-") to swap between resolutions.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
intheCommented:
about your second comment it could be either that isnt set right and causing some conflict.

can you get to the bash prompt to run setup?
btw if i remember correctly from memory its in
 /etc/X11/wmconfig/setup

0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

mwnCommented:
A good thing to know: You can allways shut down the XWindows with "CTRL-ALT-BACKPSACE" ... You don't need to hit the off-switch !!!
0
intheCommented:
yes good point
hitting the off switch isnt such a good thing in linux ;-)
it can just cause more headaches when next you reboot..
0
niemeyerCommented:
It's a very simple problem, your X server is configured to use a mode bigger than your current resolution. Just edit the file 'XF86Config'  (inside /etc/X11)  and search for a line like this at the bottom of the file:

Modes "1152x864" "1024x768" "800x600"

Make sure you are editing the line for your configured driver (svga, vga16, etc).
You'll probably have more resolutions and with a different order. Remove every resolution but the one you want to use and make sure your "ViewPort" (below the last line) is set to "0  0".

Everything else should be ok.
0
Avenger111199Author Commented:
None of this seems to work,I have re-installed linux about 3 times and for some reason it doesn't like my Gateway 17" EV700 Monitor or Mpact 2 4MB 3-D AGP Graphics card.(neither of which is listed on the installation).It's been set for just about every possible combination using the full documentation I have.When I run startx I now get- Fatal server error: no screens found & Display modes could not be resolved.The Installation routine always sends me back and around and again unable to get the probe to work.It found the scsi card however.
0
eugenetswongCommented:
Sometimes, it depends on how you set up the monitor info.

X Window likes to use something called vitual desktop. This allows you to have a resolution of your own choosing, but with a desktop of a larger resolution.

My line near the bottom of the file will look like this:
Modes "800x600" "640x480"

If I needed a large virtual desktop, I'll add a line under it [if I recall correctly]:
virtual "1024x768"

You might also want to pay attention to the horizontal and vertical frequencies.

Like 1 of the guys already said, try pressing those 3 keys to swap between resolutions.

Just a note: usually the order of the modes will start off from smallest dimensions to the biggest. I usually modify it to look like the above to make my favorite 1 the first 1 listed.

Hope this helps.
0
Avenger111199Author Commented:
Unfortunately gang I have just found out from xfree86.org that there is no server for the Mpact 2 chipset...nobody has even tried to develop a driver,and nobody probably will in the near or far future. My options are to use the mono server,vga16 server,write my own driver,or-guess what? Buy a new graphics card! I will be trying some of the above solutions, thanks for your help.
0
intheCommented:
as a note i also had to swap graphics cards when i installed linux about 3 months ago so i know how annoying it can be but do persist as it's worth it in the end ;-)
ive had to re-install about 6-7 times and everytime you learn a little more ,it really helps also to write down what settings you try etc for later reference.
good luck..
0
Avenger111199Author Commented:
To:Niemyer&eugenetswong-Your answers were excellent,however inthe was following very closely,and was the first to respond I thought that I could also award points to you both as well( I misread the instructions) as there is no "real" answer to the question because the card is not supported.I will keep this in mind when you respond to my questions in the future.Thank You.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.