• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 306
  • Last Modified:

Redhat 6 into SCO 5 via PPP/chat

I am using a Linux (RedHat 6) to dial into a SCO UNIX (Openserver 5) and connect via PPP/chat.

Everything is OK except 1 small point. My CHAT script falls over because of the SCO box flushing out the modem responses. This is documented and I need to put in delays into the script:

e.g. ogin: MYUSERNAME assword: MYPASSWORD

becomes

ogin: \d\dMYUSERNAME assword: \d\dMYPASSWORD

However my tail -f var/log/messages tells me that the username being sent is in fact ddMYUSERNAME. For some reason the backslash is being ignored and not acting as an escape character. And of course the required delay is not happening.

Any ideas? Thanks
0
mikhael
Asked:
mikhael
  • 2
1 Solution
 
rwenzlaCommented:
What are you using to edit the script?  If you are using a GUI frontend (like linuxconf) it might be stripping the "\"'s before they are written to the script file.

Find the script (probably in /etc/ppp) and check.  Edit in a text editor if they're not in there.
0
 
mikhaelAuthor Commented:
rwenzla

No am using emacs (not in X), so don't have that problem.

Cheers
0
 
emikoCommented:
Try 2 \'s    e.g. \\d\\d

The \ is a special character in Unix and sometimes
passing \'s around in shells and scripts can be problematic.
0
 
mikhaelAuthor Commented:
Worked perfectly,thanks. :)

I wish it was mentioned in the README's and HOWTO's though :(
0

Featured Post

Free Tool: SSL Checker

Scans your site and returns information about your SSL implementation and certificate. Helpful for debugging and validating your SSL configuration.

One of a set of tools we are providing to everyone as a way of saying thank you for being a part of the community.

  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now