PnP modem and com ports

I have a us robotics 56k faxmodem (internal).  I use win98se.

I want my system configured such that my modem sits on com3 and I have com1 and com2 open on the back panel.

The strange thing is, the modem seems to move around.  Sometimes it chooses com2, and sometimes it chooses com3.  How does one control this?

Also, if I utilize the jumpers on the modem to force a particular com/irq arrangement, then windows no longer recognizes the modem.  It detects it as "Unrecongizes hardware" or something like that.

What I'd like to know is how does the BIOS, windows, and the modem coordinate to determine such things as com ports and irq's?

Then, what control do I have to force a particular arrangement?
red5Asked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

colinccmCommented:
If PNP Modem, this auto assgin I/O adress & IRQ. Sometimes set-to com2 or com3.My computer has this case, but not connect to com2.
Maybe your computer has other hardware to assgin 03E8H, then modem set-to com2.
(03E8H for com3 I/O address)
Or, your com2 port error.Becasue PNP modem on normal, FIFO to com port.
If com2 free, modem choose to com2, if com3 free, modem choose to com3.
You test your hardware.
0
red5Author Commented:
I didn't fully understand your comment, but I know that both com2 and com3 work - because the modem works on both.

The only other hardware connected is a palm pilot hotsync cradle attached to com2 via the 9-pin connector on the back - but I don't think the computer would detect this.

My problem is, when my computer chooses com2 for the modem, I can't hotsync my palm pilot.  (I can't seem to get the hotsync to work on com1 - don't know why)
0
OttaCommented:
> If I utilize the jumpers on the modem to force a particular com/irq arrangement,
> then Windows no longer recognizes the modem.
> It detects it as "Unrecognized hardware" or something like that.

Set the jumpers to COM3 and an unused IRQ. (4=COM1, 3=COM2, 5=?sound-card, 7=printer, so avoid these IRQs).

Use "Add New Hardware", and do NOT let it try to detect new hardware.
Instead, indicate that you want to install a modem.  Windows will let you specify the COM/IRQ settings which you have selected, via the jumpers.
0
Powerful Yet Easy-to-Use Network Monitoring

Identify excessive bandwidth utilization or unexpected application traffic with SolarWinds Bandwidth Analyzer Pack.

phandokoCommented:
I have the same modem as yours, and encountered the same problems too.

I first tried to change jumper to PnP but it detected "unrecognised hardware".
So i left it at Com2.

what i did is to download the latest driver from 3Com. it is a filename called mdm3com.exe

it work fine after using their latest driver.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
red5Author Commented:
From your description, it sounds like you couldn't get it to work *unless* you had the jumpers on.  I can't get it to work *if* I have the jumpers on.

However, I will make sure I have the latest drivers...
0
amit_panjwaniCommented:
try this

go to bios setup

go to settings where u have ISA/PCI Slots option

there Choose <MY MODEM SLOT>

Make it non Plug and play

may be that should solve ur prob
0
red5Author Commented:
sorry - I've been having other problems with my computer that's preventing me from playing with this stuff right now.

I'll post another comment after I have more information...
0
bdrawerCommented:
The modem will move to com 3 if com 2 is being used.  It is dynaic within windows and the setttings as used ithe the drivers will not let it be set manually.  

My suggestion is simple, let it move becae your bios will set com 1 and 2 as required with the modem moving around to 3 as required.  Who cares.  This attitude also led me to a different modem.
0
MoondancerCommented:
This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed.  Also a question is posted there specific to these changes that apply to the experts here.  Also, I am including the link to our All Topics, since many new ones have recently been added.

http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
http://www.experts-exchange.com/jsp/zonesAll.jsp
 
Thank you,
Moondancer
Moderator @ Experts Exchange
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Networking Hardware-Other

From novice to tech pro — start learning today.