apache server

i try to install apache_1.3.6 but....

# ./configure --prefix=/usr/local/bin/apache
Configuring for Apache, Version 1.3.6
 + using installation path layout: Apache (config.layout)
 + Warning: no Perl interpreter available for support scripts.
 + Perhaps you have to select one with --with-perl=FILE.
Creating Makefile
Creating Configuration.apaci in src
Creating Makefile in src
 + configured for Solaris 270 platform
 + setting C compiler to cc
 + setting C pre-processor to cc -E
 + checking for system header files
./Configure: make: not found
 + adding selected modules
./helpers/TestCompile: make: not found
 + doing sanity check on compiler and options
** A test compilation with your Makefile configuration
** failed. This is most likely because your C compiler
** is not ANSI. Apache requires an ANSI C Compiler, such
** as gcc. The above error message from your compiler
** will also provide a clue.
 Aborting!                              

can anyone help?
paul
paulwhelanAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

ahoffmannCommented:
0
paulwhelanAuthor Commented:
when i try to install gcc by doing

# ./configure --build=sparc-sun-sunos7
loading cache ./config.cache
checking host system type... sparc-sun-solaris2.7
checking target system type... sparc-sun-solaris2.7
checking build system type... Invalid configuration `sparc-sun-sunos7': system `
sunos7' not recognized

checking for gcc... no
checking for cc... no
configure: error: no acceptable cc found in $PATH
#                                              

do i have to get cc (whatever that is)
do i have to change something in my path?
help!
paul
0
ahoffmannCommented:
why do you not check the suggested web site?
All the programs you want/need are there, even as precompiled binaries
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Cloud Class® Course: Microsoft Exchange Server

The MCTS: Microsoft Exchange Server 2010 certification validates your skills in supporting the maintenance and administration of the Exchange servers in an enterprise environment. Learn everything you need to know with this course.

paulwhelanAuthor Commented:
a lot of the links are broken
can u be more specific in recommending a website
and what exactly to click on to download
thanks
0
paulwhelanAuthor Commented:
sorry im getting confused here....

i _did_ download gcc from sunfreeware.com
and tried the
# ./configure --build=sparc-sun-sunos7
as i said above
but i ran into the problems that i mentioned above.....
which no one has answered yet

thanks
paul
0
paulwhelanAuthor Commented:
when i clicked on that i got a massive page
starting with

# PaCkAgE DaTaStReAm
SMCapache 1 5392
# end of header
icons/alert.black.gif 0644 bin bin 242 22907 824989552
1 f none apache/icons/alert.red.gif 0644 bin bin 247 24025 824989552
1 f none apache/icons/apache_pb.gif 0644 bin bin 2326 54855 824989552
1 f none apache/icons/back.gif 0644 bin bin 216 20071 824989553
1 f none apache/icons/ball.gray.gif 0644 bin bin 233 19733 824990538
1 f none apache/icons/ball.red.gif 0644 bin bin 205 17687 824990538
1 f none apache/icons/binary.gif 0644 bin bin 246 24143 824989553
1 f none apache/icons/binhex.gif 0644 bin bin 246 22826 824989554
1 f none apache/icons/blank.gif 0644 bin bin 148 12667 824989554



what am i meant to do with this link?
thanks
paul
0
ahoffmannCommented:
Shift-Key + Click
# I aggree, this site is not intuitive
0
paulwhelanAuthor Commented:
i sent this to my server via ftp and tried to gunzip it
but it said its not in gzip format!!!

(i sent it in ascii and also in binary but neither worked!)
0
ahoffmannCommented:
probably ist just tar format
FYI, sometimes the browser request the server to (g)unzip the file first, before sending; unfortunately the browser still gets the file with the extension .gz (which does mean nocthing on UNIX ;-)
0
paulwhelanAuthor Commented:
# mv apache-1_3_6-sol7-sparc-local.gz apache-1_3_6-sol7-sparc-local_tar
# tar -xvf apache-1_3_6-sol7-sparc-local_tar
tar: directory checksum error
#                      
0
ahoffmannCommented:
hmm, did you get it with the browser, or ftp?
I had no problems with it.
0
paulwhelanAuthor Commented:
browser....
0
ahoffmannCommented:
try getting again, probably with ftp instead of browser
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Unix OS

From novice to tech pro — start learning today.