SCSI emulation in ATAPI CDRWs

I have recently recompiled my kernel in order to add scsi host emulation for my ATAPI CDRW drive, yet when I reboot, it is still recognized as an IDE drive and not as scsi.  Is there any way to force the SCSI emulation on the drive?
bosozokuAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

psimationCommented:
Need more info, what is your kernel?
Kernels older than 2.2 cannot let go of the ide devices, so you will have to upgrade.
read the CD-Writing-HOWTO in your docs folder, you will need to make a couple of other changes to your system as well.
Good luck
0
Barn_OwlCommented:
psimation is not really correct about older kernels, the 2.0.30 and up kernel where actually abit easier to setup for cdrw. You jus added the line append="hd*=ide-scsi"  to your lilo.config in the linux section.This also works on the 2.2.10 and higher kernels. They did some thing a little difernet in the 2.2.0 -2.2.9 kernels
0
bosozokuAuthor Commented:
I have tried the things you have mentioned, but the next time I tried to reboot after the "loading linux...." came up, I recieved an error along the lines of not enough input, system halted.  Does anyone have any idea what this means??

Oh and I am running kernel version 2.2.12
0
The Ultimate Tool Kit for Technolgy Solution Provi

Broken down into practical pointers and step-by-step instructions, the IT Service Excellence Tool Kit delivers expert advice for technology solution providers. Get your free copy for valuable how-to assets including sample agreements, checklists, flowcharts, and more!

Barn_OwlCommented:
I may not have been clear the 'hd*' meant hd plus the drive letterlike hdc or hdb. You may need to boot from the install or rescue disk to get back in.
0
bosozokuAuthor Commented:
I understood the lilo.conf part of what you told me but my recompiled kernels aren't working at all.  I'm not sure what to do.
0
Barn_OwlCommented:
Have you attempted reinstalling the orginal kernel? It should have the modules need already built.This at the least would get you working a agian.
0
jester911Commented:
If you can get back into your system recompile you kernel like thus:
/usr/src/linux (2.2.xx)
sh: make mrproper
sh: make configure or make menuconfigure or make xconfigure
IDE-ATAPI CD ROM support n
SCSI Emmulation y
SCSI CD-ROM support y
Generic SCSI Support y
SCSI support  y
DO NOT SELECT SCAN ALL LUN"S answer "no" to that option
Make these a part of the kernel and not modules. avter you save the setup.

sh: make dep
sh: make clean
sh: make bzImage
sh: make modules If you have modules compiled outside the kernel
sh: make modules_install (see above)
sh: make bzdisc (insert a floppy first)
sh: make bzlilo
copy your bzImage from /usr/src/linux(2.2.xx)/arch/i386/boot
and put it in /boot

In your /etc/modules.conf add:
alias scd0 sr_mod
alias scd1 sr_mod
alias hostadapter ide-scsi  
options ide-scsi ignore=hdb (or your cdrom)
options ide-scsi ignore=hdd (or your cdrw)

You will need to change your lilo.conf to boot the new kernel (bzImage) and add an append line:
append="hd(whatever your cdrw is)=ide-scsi.
if you already have a append line there just put a space after the last character and before the last " to read: hdb=ide-scsi you should already have an append line there if you had to tell the kernel to recognize more than 64M of RAM

you will also have to adjust your /etc/fstab to read
something like:
/dev/scd0 /mnt/cdrw iso9660 user,exec,dev,suid,ro,noauto,owner 0 0
and :
/dev/scd1 /mnt/cdrom iso9660 user,noauto 0 0

NOTE: scd0 is = to IDE primary and scd1 is = to IDE secondary. so adjust these lines accordingly.

be sure that the mount points are correct in /mnt

Now the test.........REBOOT........if everything worked
at a shell type: cdrecord -scanbus
it should now recognize both your cdrom and your cdrw as scsi devices.

I take very little credit for this information. I recieved it getting help myself. Thanks goes to aa0na and tq3407@lc (Marshall) It worked for me and hopefully it will work for you.........Good Luck and have fun!!

            jester911  (Brad)
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
Barn_OwlCommented:
One change to a bove. If you use teh bzlilo then you do not have to move the bzImage that is all done by bzlilo and it also redoes teh lilo for you.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Linux

From novice to tech pro — start learning today.