How do I install Apple Universal interfaces into codewarrior pro 4

     I have Codewarrior professional 4 and would like to install the new (3.3) Apple SDK-interfaces (.p,.h, etc)  I tried just replacing the contents of what seemed like the right folder in codewarrior with the contents of the SDK download.  For example I replaced /macos support/interfaces/universal interfaces/ with the contents of /PInterfaces/ from the SDK download.

      When I did this all hell broke loose with codewarrior returning odd errors and claiming things that should be defined were undefined.


      How should I do this?  Thanks.
DrakkenAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

boonstraCommented:
Universal Headers 3.3 is a delta release - it contains only the files that changed and not the complete release.  Therefore you want to drag the contents of the :Interfaces&Libraries:Interfaces:CIncludes: folder into the corresponding CodeWarrior :Universal:Interfaces:CIncludes: folder.  You don't want to replace the entire folder.  Ditto with :PInterfaces:, etc.

Be sure not to replace the fp.h file, as Metrowerks has modified it from the original Apple version.  (I don't remember if it is in the 3.3 release.)  See ":MacOS Support:MacOS Support Notes.txt" for more info on the way Metrowerks organizes header and library files.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
boonstraCommented:
Actually, checking the Apple ftp site again, there appears to be a I&L 3.3 that is complete, so I'm not certain what I said above applies in your case.  

If it isn't, let me know what sorts of errors you are getting.
0
DrakkenAuthor Commented:
The file I downloaded was called "Univ_Interfaces_3.3.img" do you know if this is the complete one or not?  In any case it appears the problems may not have come from the new interfaces but instead from corrupted project settings.

      
0
boonstraCommented:
The ReadMe files say that it is _not_ a complete MPW development release, but say that it is complete for CodeWarrior.  An examination of the contents confirms that.  So I suspect your problem is elsewhere, as you suggest.
0
DrakkenAuthor Commented:
thanks for your help!
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
System Programming

From novice to tech pro — start learning today.