HP-8100 w/directcd software hangs - help!

Was using easy cd creator software all the time to copy audio cds, then it for no appearent reason it started hanging during disk image.  Have set 1000 meg virtual win95 mem. defraged HD with almost a gig free for image file.  Was getting to 89% of image done when hung but sometimes only 14% or so.  When it hangs, I can't cancel the program, or even shut down.  

BIG delays in everything I do after hangs.  Accessing explorer leaves it open without left directorys showing and it hangs. All programs end up showing (not responding) at 3 finger salute. Tried manual write mode in program also (as one source disk is larger then blank) but it would hang on test write at less than 1%.  A clue might be that when it hangs, the reader drive light stops blinking.  I can't even eject the source disk after that.

I'm thinking drives out of sync or something, but what do I know :) Tried reinstalling drivers and writer programs (even upgraded BM for bufferunderrun problem a while back).  No change.  Have done all the upgrades, tweaks, (like vcache) etc.

AMD K6/2 350->400 win95 ver. 4.00.950 B - 128 meg 100mhz - Mitsumi CD FX3400S!B is the reader.  Also, reader and writer both read OK on audio and data.  Thanks for any help, Ken
hardlockAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

hardlockAuthor Commented:
Edited text of question.
0
bparnesCommented:
Here's some advice from HP on making sure that DMA is not enabled for your 8100.

Go to the Control Panel and open the System Icon, select the Device Manager tab in the System Properties window and double-click CD-ROM.
 
Double-click the CD-Writer drive, go to the Settings tab and verify that
Disconnect and Auto Insert Notification are the only options selected.

If the "DMA" option check box is checked, uncheck it and restart the system for the change to take effect.

Finally, go back into the Device Manager and verify that the DMA option remains unchecked.
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
hardlockAuthor Commented:
Been there, done that.  In fact, I don't have any DMA options in device manager at all under CD.  With the VIA chip set I have, I had to DL new BM drivers to even get the option.  This was done to eliminate the bufferunderrun error I got before I could even use the writer.

The new drivers allow me to rerun the setup and choose enable/disable DMA for any ofl the drives.  I have (and haven't changed since I got it working) the HD set to ON (UDMA), the CD to ON (DMA) and the writer to DMA OFF.

0
hardlockAuthor Commented:
bparnes - I'm going to submit your comment as an answer since you got me thinking about the DMA stuff.  It turns out that I needed to turn off the DMA settings for BOTH the CDROM and HP writer.  Maybe since they are on the same IDE channel?  Anyway, thanks for the help, they work fine now.
0
bparnesCommented:
Glad I was able to help solve this one. Enjoy your 8100.
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Hardware

From novice to tech pro — start learning today.