• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 294
  • Last Modified:

networking win98 and linux

my smb.conf test good, smbclient test good, ping test good. I see my linux server in network neighbor, but every time I try to connect it ask for a password,net view gives me error 86,  but what password that my netbios name in smb.conf i tried leaving it blank and even used my user name password no success HELP! security = user, netbios name = electronics, workgroup = industrial. I even edited my regedit to enable plain text passwords.
0
dlm1013
Asked:
dlm1013
1 Solution
 
dlm1013Author Commented:
Edited text of question.
0
 
dlm1013Author Commented:
Please help i being trying for weeks search after search.
0
 
tolmedaCommented:
Try using the root account ("root" as userid, and root password) and let me know if it works. If not then I'll have to whip out my some notes and do some research...
0
Receive 1:1 tech help

Solve your biggest tech problems alongside global tech experts with 1:1 help.

 
dlm1013Author Commented:
when i click on the server in network neighbor hood all it ask for is a password no user name.
0
 
Manfred BertlManagerCommented:
pls post your smb.conf
0
 
tmossCommented:
the problem is that the connection requires a username AND password. Unfortunately Win9x only prompts for a password and just assumes the username of the currently logged on user (NT prompts for both by the way). The username that you are logged into the Windows box with must exist on the Samba server (either as an account on the Linux machine or "aliased" in Samba), then use the password appropriate to the that Linux account.
0
 
kuipershCommented:
Did you define a section public that defines a shared directory where users can read and write? Set the following in SMB.CONF:
[public]
comment = Public Stuff
path = /publicdir
public = yes
writeable=yes

Create the publicdir and set the rights to read/write for all users:
chmod a+rw /publicdir

Stop and start SMB to commit the changes in SMB.CONF
0
 
dlm1013Author Commented:
here is my smb.conf
[global]
netbios name = elctronics
password level = 0
username level 0
unix password sync = yes
log lovel = 0
ls level =55
peferred master = yes
domain master = yes
log file = /var/log/samba/log.%m
socket options = tcp_nodelay


[tmp]
path = /tmp
print ok = yes
read only = no
guest ok = yes
[home]
read only = no
browseable = yes

[public]

path = /home/public
write = yes
read only = yes
guest ok = yes
browseable = yes
0
 
dlm1013Author Commented:
i do log in as a user on my windows box and the user is allso the same in my linux box
0
 
dlm1013Author Commented:
i do log in as a user on my windows box and the user is allso the same in my linux box
0
 
dlm1013Author Commented:
by the way I running mandrake 601 and win98 second edition
0
 
dlm1013Author Commented:
after running for a while my tcpdumb displays this
8:24:57.004226 .electronics.1024 > 192.36.148.17.domain
:57412 NS?  . (17)
0
 
dlm1013Author Commented:
hey I did a tcpdump on my linux box and here is the readout when i try to connect by clicking on electronics in network neighbor

17:07:16.228844 10.0.0.1.1030 > .electronics.netbios-ssn:
ack 1 win 8760 (DF)

#here is what i see when iamn't doing anything
17:23:17.006536 10.0.0.1 > .electronics: icmp: udp port domain unreachable

my subnet mask 255.0.0.0 and ip address for my windows bos is 10.0.0.1
and my ip address for my linux box is 10.0.0.2 and mask is
255.0.0.0
0
 
kuipershCommented:
I use the same adress range (10.0.0.1 - 10.0.0.9).My server acts o.a. as router and DHCP server which is normally the lowest number in the range, so 10.0.0.1.
However, the subnetmask I use everywhere is 255.255.255.0. Perhaps that's your problem....
0
 
MoondancerCommented:
This question was awarded, but never cleared due to the JSP-500 errors of that time.  It was "stuck" against userID -1 versus the intended expert whom you awarded.  This corrects the problem and the expert will now receive these points; points verified.

Please click on your Member Profile and select "View Question History" to navigate through any open or locked questions you may have to update and finalize them.  If you are an EE Pro user, you can also choose Power Search to find all your open questions.

This is the Community Support link, if help is needed.  Also a question is posted there specific to these changes that apply to the experts here.  Also, I am including the link to our All Topics, since many new ones have recently been added.

http://www.experts-exchange.com/jsp/qList.jsp?ta=commspt
http://www.experts-exchange.com/jsp/zonesAll.jsp
 
Thank you,
Moondancer
Moderator @ Experts Exchange
0

Featured Post

[Webinar] Improve your customer journey

A positive customer journey is important in attracting and retaining business. To improve this experience, you can use Google Maps APIs to increase checkout conversions, boost user engagement, and optimize order fulfillment. Learn how in this webinar presented by Dito.

Tackle projects and never again get stuck behind a technical roadblock.
Join Now