Apache and htaccess files

I have just installed the latest version of Apache.  I wanted to test out the htaccess capability of the server so I created a directory called foo, which is under the htdocs directory.  For some reason it looks like Apache just ignores the htaccess file and displays the index page that is in the foo directory.  Is there some setting that I missed in setting up the httpd.conf file that makes the default htaccess behavior turn off?  Thanks!
alpineAsked:
Who is Participating?

[Webinar] Streamline your web hosting managementRegister Today

x
 
egbservicesConnect With a Mentor Commented:
Find the file apache/etc/access.conf and change the following setting from None to All to allow .htaccess files to work.
AllowOverride None
AllowOverride All

I will happely take the points if it works... Edi
0
 
egbservicesCommented:
If you are interested the following is our access.conf file
--------------------------------------------------------------

# access.conf: Global access configuration
# Online docs at http://www.apache.org/

# This file defines server settings which affect which types of services
# are allowed, and in what circumstances.

# Each directory to which Apache has access, can be configured with respect
# to which services and features are allowed and/or disabled in that
# directory (and its subdirectories).

# Originally by Rob McCool

# This should be changed to whatever you set DocumentRoot to.

<Directory /var/lib/httpd/htdocs>

# This may also be "None", "All", or any combination of "Indexes",
# "Includes", "FollowSymLinks", "ExecCGI", or "MultiViews".

# Note that "MultiViews" must be named *explicitly* --- "Options All"
# doesn't give it to you (or at least, not yet).

Options Indexes FollowSymLinks

# This controls which options the .htaccess files in directories can
# override. Can also be "All", or any combination of "Options", "FileInfo",
# "AuthConfig", and "Limit"

# Changed by WFY, 16 August 1999, from None to All to allow .htaccess files to work.
#AllowOverride None
AllowOverride All

# Controls who can get stuff from this server.

order allow,deny
allow from all

</Directory>

# /usr/local/etc/httpd/cgi-bin should be changed to whatever your ScriptAliased
# CGI directory exists, if you have that configured.

<Directory /var/lib/httpd/cgi-bin>
AllowOverride None
Options ExecCGI
</Directory>

# Allow server status reports, with the URL of http://servername/status
# Change the ".nowhere.com" to match your domain to enable.

#<Location /status>
#SetHandler server-status

#order deny,allow
#deny from all
#allow from .nowhere.com
#</Location>

# You may place any other directories or locations you wish to have
# access information for after this one.
0
All Courses

From novice to tech pro — start learning today.