FP98 or InterDev 6 to access SQL 7 database?

Could somebody explain to me (like I'm 3 years old) how to access a SQL 7 database using FP98?  Or point me to a tutorial?
I have installed FP98, sql 7 locally, I even have Interdev 6 installed but it's kinda beyond me (and I don't have time to learn it right now).
I'm switching from Dreamweaver to FP because it's for an intranet on an NT network.  I have tried and tried but I cannot access the DB.
I will even use Interdev (that's the real goal down the road) if you can point me to a good tutorial on that.  I have PWS (v 3 i think) w FP98 extensions.
Tanks
pcainAsked:
Who is Participating?
I wear a lot of hats...

"The solutions and answers provided on Experts Exchange have been extremely helpful to me over the last few years. I wear a lot of hats - Developer, Database Administrator, Help Desk, etc., so I know a lot of things but not a lot about one thing. Experts Exchange gives me answers from people who do know a lot about one thing, in a easy to use platform." -Todd S.

joejansCommented:
Make sure you have the NT Option Pack for PWS.  You will need to point an ODBC link to the SQL database you wish to connect to from Control Panel.

Ultimately, you will probably need to use something like ASP to access your database.
0
NickRackhamCommented:
Providing you have the access rights to the SQL server, choose a new database project in interdev, and the wizard will walk you through the connection process. I know that saying it's very simple can offend, but it really is easy.

The samples that come with Interdev will indicate how a connection is made and how to query the database.

Regards

Nick
0
pcainAuthor Commented:
To NickRackham :
Yes I did create a global.asa file in Interdev and created a query and added a recordset control to the page.  I just can't get any data into the web page.  I've tried using a grid and simple text boxes. I've pointed the text box to 'recordset 1' and chosen the field to display.  Nothing comes over.  Maybe I don't have PWS installed correctly or something?  I can never get Asp Debugging to work.

To Joejans:
I have the option pack installed. NT4 SP4 IE5. I've created an ODBC connection in the control panel. I get an error like IUSR.... could not connect - does not have access permission to the database.
I am trying to log in SQL as username=sa pwd=  The web page seems to create its own user name and password to connect.
0
Upgrade your Question Security!

Your question, your audience. Choose who sees your identity—and your question—with question security.

TTomCommented:
Not sure you can use ASP debugging on PWS, but I could be wrong.

In terms of your database access, are you specifying the SA account in the connection string of the global.asa?

You should also check the NT permissions on the directory for the database.  Unless I miss my guess, SQL server is very happy with the SA account, but NT is looking for a valid NT account to access the directory/file.  By default, the web server uses IUSR_machinename.  You will probably need to either add that account to the permissions on the database/directory or allow a more 'general' (i.e., Everyone) access.

(FWIW, granting Everyone access is not a real great idea unless your data is not at all sensitive.  In fact, granting Everyone ANY sort of access on your machine is not the best idea in the world, even though it is pretty much the Windows default.)

HTH,

Tom
0
pcainAuthor Commented:
Thanks for your insights TTOM, I will give them a try as soon as I get the chance.  The rest of this week is busy for me and hopefully by friday or monday I can apply your suggestions.
PWS crashed and burned and I will re-install as I can.
0
TTomCommented:
Best luck!  Understand busy.

Tom
0

Experts Exchange Solution brought to you by

Your issues matter to us.

Facing a tech roadblock? Get the help and guidance you need from experienced professionals who care. Ask your question anytime, anywhere, with no hassle.

Start your 7-day free trial
pcainAuthor Commented:
Ttom, sorry I'm a week late getting back. I re-installed.  The problem I had turned out to be the DB. I didn't have the permissions set up correctly...
Thanks for your patience.
0
TTomCommented:
No problem.  Glad it's working for you now.

Thanks,

Tom
0
It's more than this solution.Get answers and train to solve all your tech problems - anytime, anywhere.Try it for free Edge Out The Competitionfor your dream job with proven skills and certifications.Get started today Stand Outas the employee with proven skills.Start learning today for free Move Your Career Forwardwith certification training in the latest technologies.Start your trial today
Web Development Software

From novice to tech pro — start learning today.