• Status: Solved
  • Priority: Medium
  • Security: Public
  • Views: 336
  • Last Modified:

Problems with ISP connection

Hi.  

I am running RH6.0 Linux basically as workstation (I have 2 accounts set up - both me for different purposes) on a 486 DX2 66Mhz with 20096KB RAM, and a Creative Labs Modem Blaster 56K MODEM.   I am using Kppp to connect to the network at work and to try to connect to the internet through my ISP by dial-up.

When I dial into work, I have no problem logging in and running any application I want (it's MUCh faster than eXceed and Windows :-)  ).  But when I dial up my ISP, I continually have problems logging in, and if I can log in, I may be able to get on the internet for a while, but slowly (over about 15 minutes) things get worse, and finally I cannot even ping my ISP's name server or even the remote IP address the ppp session says I am connected through.

I have been on the phone with my ISP, and he only does Windows, so he isn't any help with Linux, but he just says it's the phone lines between him and me (some are very bad).

I am not sure what to do about that.  But the thing that mystifies me even more, is that after I connect to my ISP, my hostname changes (say if I do an su root or open a new kvterm) to rack-xx.deltaforce.net at some point, and even after I disconnect from my ISP, it stays that way so that I cannot run any other X-apps - I have to shutdown and reboot the computer (there may be another way to do this, but that's part of why I am writing).  When I dial up my work, this does not happen.  I can work for hours online without any problems, and I can open new kvterms without the hostname changing, performance degrading or X-apps refusing to run because the cannot access the server.

I have copied a ppp account in Kppp of my dialup to work, then changed only the name, number dialed, and anything else that might be specific to my ISP, but that doesn't work either.

So, my first question is this - when I dial in to work or to my ISP, I am given an IP address dynamically.  Is there a file or variable in my system that has that value stored in it while I am connected, and then is reset after I disconnect (or is suppose to reset)?  If so, what file is it and where is it?  I see that HOST=rack-xx.deltaforce.net when I do an ENV after I disconnect from my ISP, but I have not been able to figure out how to change that.  No command I have tried changes it.  Do I have something set wrong or setup incorrectly?

Second, when trying to dial up my ISP, while it says it is logging onto the network, I get disconnected, and the log file says the MODEM is being sent a hangup.  Both my MODEM and PPP timeouts are set at 900 seconds.  Why would this be happening.  My ISP says it is noise on the line causing it.

Any help anyone can give me will be appreciated.  I have been frustrated with this ever since I tried to connect to my ISP.  I seem to be getting farther, but in other ways it seems to get worse.   :-(

One other thing is that I can connect and do whatever I want through my ISP and work from my Windows 98 Laptop.

Thanks.

Rick Davis
rdavis@deltaforce.net
0
wgmrd
Asked:
wgmrd
  • 5
  • 2
1 Solution
 
wgmrdAuthor Commented:
Adjusted points to 150
0
 
stardrakeCommented:
For the hostname problem, you may want to try HOST=myhost.com; export HOST from a prompt.  This may do what you need. Also, you may want to look into changing permissions on the file that contains the hostname (varies from Linux to Linux).  

   --- Joel
0
 
wgmrdAuthor Commented:
I can change the hostname back by doing a "hostname localhost.localdomain", but then I cannot access any web pages. I have found that the /etc/HOSTNAME file is usually empty when I dial into work (which works just fine), but when I dial into my ISP, the ISP, at some point - maybe when I try to go to a web site, puts the name rack-xx.my.ISP in the file.  I can recover, but cannot get both internet and local stuff to work.  since I am using the same /etc/HOSTNAME file (I think) for both dialup situations, I don't know if changing the permissions on the file, which are 644, would do any good.

One question - I have the permissions on pppd and kppp set at 4711.  The book I have said to do that.  Is that a problem?
0
Get your problem seen by more experts

Be seen. Boost your question’s priority for more expert views and faster solutions

 
stardrakeCommented:
Unfortunately I do not know enough about pppd and kppp to answer your last question.  I believe that the reason your hostname changes when dialing to your ISP is because they have their DHCP server configured to hand out a hostname.  Does your Win98 laptop also have it's hostname changed when it dials to your ISP?  I would think that it should, but I doubt that Windows would really care if it did.  Sorry that I am unable to help more.

  --- Joel
0
 
wgmrdAuthor Commented:
I don't know if the Windows machine has it's name changed or not.  Do you know how I might find that out?
0
 
sirwnstnCommented:
Check out this link:

http://axion.physics.ubc.ca/ppp-linux.html

It goes through in DETAIL how to set up a ppp connection using pppd- all the config files and everything.  It'll even teach you how to watch the log files created by pppd so you can troubleshoot.  Happy hacking.
0
 
wgmrdAuthor Commented:
THis answer from sirwnstn probably had the info in it I needed, but there is so much info in these insrtuctions that I am not sure what really applies to using Kppp.  

I found ou that the reason my hostname was being changed was that I didn't have a computer name set in /etc/hosts other than localhost.localdomain.  Once I set a computer name in addition to that with IP 127.0.0.1, it was fine.

Also, a friend who uses a different ISP (mindspring) came over last night and we tried to connect ot his account at Mindspring.  It worked fine.  Since dialing into work and dialing into Mindspring works fine with the same setup I cannot get into my own local ISP with, I am changing from my current ISP to Mindspring as soon as possible.  Besides, they have help desk people that use Linux, though they don't officially support it. So,  thanks for the help.

Rick
0
 
wgmrdAuthor Commented:
Also, stardrake probably gave me the right answer on the hostname problem.  I just didn't recognize it.  I tired to see today how to accept his answer, but couldn't.
0

Featured Post

Free Tool: ZipGrep

ZipGrep is a utility that can list and search zip (.war, .ear, .jar, etc) archives for text patterns, without the need to extract the archive's contents.

One of a set of tools we're offering as a way to say thank you for being a part of the community.

  • 5
  • 2
Tackle projects and never again get stuck behind a technical roadblock.
Join Now